Vector Curve No end Points get processor error cutting


I am working with a plasma cutter. I have a file of a car with single lines and lines that have curves with segments in it. When I run the post processor, everything is great. I take it to the plasma cutter and I get a load error. Complaining that a line has no end points. This used to work in Sheetcam 6.0.30. I tried to remove and install, but using windows to uninstall application is not removing everything. So I down loaded the development version and ran the same file and it works.

I have attached two captures, with g-code and picture of cut, and in the one that fails you see a big wrap a round circle. Again this used to work. Sheetcam is having troubles with segmented lines(open vector)

Any ideas and help appreciated
Eddie Taxi-line-6.0.30.job (237 KB)

This has been the subject of a thread on here before, I’m just having trouble remembering what all was said. It seems like there was a problem, and there is a workaround for it. I’m under the impression it should have been fixed by now.
At any rate, as far as I can remember, there is an option change you can make to get it to quit doing the circles. I’m not at all sure, but it seems like it was options → application → drawing import → minimum segments for arc fitting = 8.

You might give that a try and see if it makes any difference, Steve
(as I said I’m not sure about this, and this may be the fix for something else!)

I tried to ass the # of segments all the way to 50, and did not work, now I am getting a line that closes the segment to cut see attached, this has to be a sheetcam bug

I think it could be a post processor issue. Could you attach a copy of your post.

Hi Les

So I created a single line/curve with 2 segments, when I apply operation/plasma/tool and say ok, it closes the curve, this is before I even run the post processor.

I have attached the sheetcam file and several screen shots as well as post processor output

In sheetcam, it shows a lot of segments, but when I drew it it was two

This is driving me crazy :slight_smile:

Line-2-Segments.dxf (11.6 KB)

attachments of job
Line-2-Segments.tap (974 Bytes)
Line-2-Segments.job (8.57 KB)

screen shots of sheetcam

The joingin line is there because you have an overcut defined in your cut operation. If you set overcut to 0 the problem will go away. This is a bug and will be fixed at some point. It has been fixed in the development version.

You have lots of segments because G-code only understands lines and circular arcs. SheetCam has to break your free-form curve down into lines and arcs. Go to Options->application options->drawing import and set the arc fitting tolerance to 0.1mm (0.004") and the number of segments for arc fitting to 4. Now reload your drawing. You will now have fewer segments along with a small drop in accuracy. The loss of accuracy is negligible for plasma.

Thanks Les. Al is working fine now and the full cut is clean now when I run simulation in NC Viewer. I am confident it will work now