validation error - no program speed found on Langmuir

I created a small .crv file in Vectric Vcarve pro and saved it for future mods if necessary
then through Vcarve pro I exported that .crv file to a .dxf file
then used Sheetcam to check the file for operation which was all good
my post processor in Sheetcam was already set up for the Langmuir Crossfire V1.6 (the latest version)
ran the post processor which created the .tap file (which is the gcode file to run on the Longmuir crossfire plasma cutter which uses Firecontrol software)
I connected to my Langmuir Firecontrol program and tried to open my file which is a .tap file and the following message appeared

Validation error
no program speed found
This program will not be loaded. Please make sure you are using the latest Langmuir systems approved post processor

now here is the wierd thing: The icon picture for the xxxxx.tap is an OPENBUILDS emblem

This has happened to me in the past, I could never get an answer from Openbuilds why this happened with Langmuir or Sheetcam. it must be a glitch in the software. nothing was ever done about it. !!!

For your info I have the Openbuilds software controlling my Openbuilds brand wood carving/cutting machine which is working great, I also have a CO2 laser using Lightburn which also works great. I also have a 3D printer and their processed and saved files also use the openbuilds icon for the Gcode

It would appear to me that the problem is no option in changing post processor

I’m not a computer nerd and struggle at times with the frustration and lack of knowledge. If it were not for youtube university I would have quit this hobby long ago.

I will post this on the following forums so others can learn from this:
openbuilds forum
Sheetcam forum
Langmuir forum
Louisianna Hobby guy forum
Vectric Vcarve forum

I have purchased licences for all the software I use. no glitches because of unlicenced software.

No experience with your system…
The icon is simply associated with the .tap extension. Do all of these programs use .tap files? If so, then most likely the last program installed associated itself with the .tap extension.
Maybe if you posted your offending gcode file somebody could spot something out of the ordinary.

Openbuilds has associated .tap files with itself. It doesn’t really matter.

In SheetCam have you set up any cut operations on your drawing? If you have not defined any cuts or if your tool has the feed rate set to 0 you would get a warning from Firecontrol.

I did not define any cut operation. Obviously I was wrong in thinking that Sheetcam would allow me to set up the cuts. I will go back to the .crv file in Vcarve Pro to make changes. Not sure at this point how far I have to go in the process. Do I need to create the gcode file and can I export that gcode file into a DXF file before bringing it to Sheetcam to turn it into the .tap file ?
Can you direct me to some related text on the net where I can find that information ?

I went back and finished the CAM portion for the cut file, easily saved it as a grbl file, then exported that file to Sheetcam and voila no error.
thanks for your help