Upgraded to 3.0.4 and having problems.

Problem one may not be a Sheetcam thing as I do not see a problem in the Gcode. After starting the cut, the torch shuts down and motion stops part way into the cut. This happens at exactly the same spot every time. I don’t see anything in the code that would shut the torch off, but seeing as how it happens at the same spot every time, I still question the code.

Problem two is that arcs are no longer cutting smooth. Small arcs are cutting as tiny line segments. Mach is acting as if it’s in exact stop mode, Very jerky movement through small arcs. Mach is set to constant velocity.

I’m using a THC301d.

The only thing that has changed since the last time I ran the machine is the Sheetcam upgrade to 3.0.4.

I’m not sure what version I had before, but I’d like to roll back to it just to see if that’s the problem. What was the stable version prior to 3.0.4?

Thanks

I can’t think of anything that would make it stop, unless you are hitting Mach’s line limit. How many lines is it executing?

Can you post a copy of your job file so I can try to figure out why the code is different.

Here is the job file and a photo of what gets cut. Mach is registered and the license file is where it should be. It looks like it cuts a certain distance then shuts the torch off. It seems to be cutting about the same distance on each letter before shutting off. It seems to be happening after a series of small arc moves.

For the cuts in the photo, I removed all Z moves, torch referencing code and shut off the THC in mach in an effort to narrow down the problem.

I’ve checked the drawing for open curves but didn’t find any. When the torch shuts off, the “Torch On” light is still lit until the program hits an M05. I don’t see anything in the code that could be shutting the torch down.

The other issue is small arcs. Mach seems to be going into exact stop mode on small diameter arcs. For instance, the arcs in the “1” are cutting as small segments in exact stop mode. Mach is set to constant velocity. Mach setting haven’t been changed in almost 6 months.

Recently I did two things. (1) I set up a new CutMaster 151 with a THC301d and I upgraded Sheetcam.

The THC I used on the 151 was removed from my CutMaster 81 and the 81 was cutting like a charm.

Thanks for any help. This one has me stumped.

Forgot to mention…If I create a file with just the “1”, it completes the cut. The arc problem is still there however.

Les…

Here is a block of code from where I had the min_arc set to .02.

N0390 G01 X4.9800 Y2.9950 F75
N0400 G02 X4.9821 Y2.9923 I-0.0223 J-0.0201 F75.0
N0410 G01 X4.9940 Y2.9757 F75
N0420 G02 X4.9954 Y2.9736 I-0.0244 J-0.0175 F75.0
N0430 G01 X5.0062 Y2.9555 F75
N0440 G02 X5.0073 Y2.9534 I-0.0258 J-0.0154 F75.0
N0450 G01 X5.0170 Y2.9338 F75
N0460 G02 X5.0181 Y2.9313 I-0.0269 J-0.0133 F75.0
N0470 G01 X5.0306 Y2.8990 F75
N0480 G02 X5.0314 Y2.8967 I-0.0280 J-0.0108 F75.0
N0490 G01 X5.0384 Y2.8733 F75
N0500 G02 X5.0390 Y2.8709 I-0.0288 J-0.0085 F75.0
N0510 G01 X5.0448 Y2.8432 F75
N0520 G02 X5.0451 Y2.8412 I-0.0294 J-0.0061 F75.0
N0530 G01 X5.0483 Y2.8181 F75
N0540 G02 X5.0485 Y2.8167 I-0.0297 J-0.0041 F75.0
N0550 G01 X5.0523 Y2.7751 F75
N0560 G02 X5.0523 Y2.7738 I-0.0299 J-0.0027 F75.0

When I set it to .06 all of these arc moves become G01 moves and the arc runs smoothly because Mach is in CV mode. The above code (G01 followed by G02) makes Mach behave like it’s in exact stop mode.

Is this a coding problem with small arcs? Mach doesn’t seem to like it when it’s coded like this. It’s not been an issue until the recent upgrade. Arcs of all sizes have always cut smooth.