Tool Library Totally Erased

I have the free version of SheetCam on my laptop and it has like 1 tool set on it just for job report purposes. I created a pipe flange that I was going to cut, saved it as a .job file because it was >180 lines of code, loaded it onto my USB drive, put it into my plasma table computer, loaded the .job file into the licensed SheetCam, and every single tool set in my library was deleted. I tried closing out of Sheetcam, removing the hard drive, even deleting the file. Nothing worked and now I have no tools to work with.

What did I do wrong, how can I prevent this in the future when I load .job files, and can this be reversed???

SheetCam job files include the tool set. When you loaded that job file with a single tool it replaced your previous tool set. As you have SheetCam set to automatically save your default tool set it overwrote your normal set when you closed SheetCam.
Do you have any jobs saved that have the full tool set? If so you can load that to recover your tool set.
There are a couple of options to prevent this happening in the future. In SheetCam go to Options->application options->annoying dialogs and turn off ‘save default toolset’. Next time you close SheetCam it will ask if you want to save the default tool set. Answer no and tell it to remember your choice. If you make any changes to the tool set in the future you need to manually save the default tool set (File->save default tool set).
Another option is in Options->application options->advanced. If you turn on ‘always use default toolset’ it will merge your default toolset with the job file’s tool set. If there are any conflicts it will ask what you want to do.

Awesome, thank you!