sketchup to sheetcam

I have used sketchup pro 7 cad for a long time and know it well, however i have now started using cnc plasma so use the sheetcam program. The problem is when i export a design from sketchup (in DXF) the sizes change when measured again in sheetcam. The sheetcam sizes are approx 10-15mm bigger than when they were drawn in sketchup. I have started using solid edge cad program and this does not seem to have a problem. I would prefer to use sketchup as its a lot simpler and quicker, anyone have any ideas why sizes change?

That’s an odd one. I would guess it is a scaling issue. Draw a square of a known size in Sketchup. Import the drawing and measure it. Make a note of the size. Now double the size of the drawing in Sketchup and import it into SheetCam. Is it double the previous size?

When you import the drawing, what units do you select in the options box that pops up?

hello again, i exported from sketchup to sheetcam a DXF file of a square 100mm x 100mm which when opened in in sheetcam was 116.7mm x116.7mm i then exported a 200mm square which when opened in sheetcam ended up as 128.7 x 128.7mm, I’m afraid my maths is way to rubbish to know if that is down to scale or if it is a random size. If it is down to scale is there a fix?

That sounds like a scaling issue in Sketchup’s dxf export. When you create the dxf does it give you the option to change the scale? If so, you want full scale.


i just had a look but i cannot see any scaling options. will sheetcam open DWG files or PDF as i could try to export in these hoping the scale problem is in the dxf translation

Are you using Sketchup pro? I believe pro has an options button when you export the file.

I am using pro but there is no scaling option given before exporting, if you send it to the sketchup layout program there is a scaling option however you can only save/export these files in pdf. I drew a few items last night on the solid edge cad program and tried them in sheetcam this morning. The sheetcam program seems to open the DXF file but nothing appears on the screen when i click on the j button the screen goes blank and when click on the m button it just shows the table and material but no part. I can open the sketchup DXF ones easliy though!

When you export dxf from Sketchup do you see an options button?

Can you post one of the SolidEdge drawings so I can take a look at it and try to figure out what is wrong.

Hello attached is solid edge drawing, Thany you for your continued help

What version of SheetCam are you using? Both of those drawings loaded orrectly into the most recent version of TNG.

I downloaded the program from the main site about 2 weeks ago i have the sheetcam TNG development version though not the stable version. I tried all the other file formats i could find today on sketchup pro but the only one that opened was the sketchup DXF files Typical as thats the one with the sizing issue!

Hello again

could you measure the thumb foot plate file i sent you to see if its a problem my end, when open it should just be a simple rectangle measuring 510mm x 85 0r 90mm

Regards Richard

Yes, It’s 510 x 85mm.


thanks for the measurements, i find it more frustrating now though as you can receive the right dimensions. Do you think this could point to a problem with the sheetcam program though as you are able to open the files and they are the correct size and i am not able to with my sheetcam program. Would it help do you think to delete the program off and reload? Am i able then to use the license i have for the new program?

Regards Richard

Reinstalling is unlikely to solve the problem. When you import the drawing a box pops up with some options. Make sure you have the scaling set to Metric. The drawing should then be scaled correctly.

I checked the box you mention on sheetcam and i t is set to metric 1.1. To put an end to this i played around with the custom scaling and have set the scale at 1.0.91, the measurments are to within a 10th of a mm over 300mm which for what i need is accurate enough for me.

Thankyou for you help

Regards Richard

I had the same issue and fixed it. To ensure this happens do the following:

----> Export dxf only with top view, camera parallel projection mode.

Note: One way to ensure the scale will be exported correctly (e.g. Full Scale 1:1) is to check the options. If Full Scale (1:1) is check you will be good. If you aren’t top view parallel project the scale numbers will be filled in and the Full Scale (1:1) option will be grayed out.

I figured this out then found the following link which also had this and a ton more info.