sheetcam not accepting dxf

I have had sheetcam for over a year. I have updated to 7.0.13. I can make a dxf on inkspape, open sheetcam go to file select dxf,it goes through process of opening but get blank screen. It worked before now it wont. Thanks for any help.

Are you inserting the dxf into a part? I don’t think you can just file…open dxf files.

You might check to see if you have the part drawn in inches and are importing metric… if you do that, the part becomes so small to almost be invisible, you have to zoom way in to even see it.

When you open the dxf file, do you have the file type set to ‘dxf’? If it is set to ‘g-code’ for instance this can happen.

I have checked all three response and still cant open dxf. I keep going through the settings and everything looks right. Will keep looking and Thank everyone for ideas. Thanks again.

I have been using Sheetcam off and on for about 5 years. I have the same issue. I am using CorelCAD and saving it in all kinds of DXF options such as R12 Binary DXF, R2018, R13, R14. I made sure that all of the “Show” buttons are enabled, such as Show machine and work, rapids, direction etc. When I import the file into the part, it shows up in the “Parts” box. This has been happening for at least 2 years. I just now looked for and found this forum. Hoping someone has experienced this issue and has answers.

Thanks in advance for any help or insight you might be able to offer.

P.S. I’m running this on a Linux machine and drawing it on a Windows 10 machine in case it matters.

My previous reply is being reviewed, meanwhile I wanted to mention that I was able to get Sheetcam to view my drawing by exporting the drawing as a R2018 ASCII DXF as opposed to saving it as the same or any other.

SheetCam won’t read binary DXF files. Binary dxf is not a popular format so I never bothered supporting it.