Sheetcam Linux Download

Our group has been using Sheetcam for years on Windows. We are moving from Mach to LinuxCNC and we would like to move Sheetcam to Linux too. When we download the file for both 32 and 64 bit versions, there is no file extension so we just get a bunch of binary code in the browser. I have tried working around this and I was able to finally get a file. However, I have tried adding every archive extension I know of to the file and I am still unable to get the file to extract.

Any ideas here?

To download the link right-click on it and select ‘save as’. To install the file right-click on it an select ‘properties’. Go to the permissions tab and make sure ‘execute’ is turned on. You can now simply double click on the file to install SheetCam.

If you want to manually unzip it you have to use the command line. Open a terminal and navigate to the folder containing the downloaded file. Next use this command (32 bit version):

gunzip SheetCam_setupV6.1.38-32

For the 64 bit version:

gunzip SheetCam_setupV6.1.38-64

Thanks for the quick reply, Les!

When I mark the file as executable nothing is happening when I go to execute the file (double click or right click and execute). When I attempt to unzip in terminal using gunzip I get a “unknown suffix --ignored” error.

screenshot image attached.


Oops, my fault - It should be unzip, not gunzip

Got it. That worked. Now I have a folder (~/Downloads/SheetCAM) with the three folders in it. Then I navigate to the data folder and right click on run-sheetcam, then properties, permissions, and check allow this file to run as a program.

After that, when I double click on the file nothing happens. When I right click and select “execute” nothing happens.

I know I am missing something simple, but I am not sure what it is.

Try executing run-sheetcam from the command line. It should give more information on what is going on.

Here you go. Looks like it is missing a dependency. I have not idea how to get this though. Screenshot attached.

Here you go. Looks like it is missing a dependency. I have not idea how to get this though. Screenshot attached.

What version of Linux are you running?

Hey Les how are you, i am having the same problem as Toolmanmax , if i double click on the icon or right click the program won’t open I am using Commandcnc and they had loaded Sheetcam on the pc for me and worked fine for a while then started having problem so i deleated sheetcam and figured i would try a fresh install

Are you using the correct download for your setup? If your machine is 32 bit you must use the 32 bit download and vice-versa. Tom has tested the latest version with CommandCNC and it worked for him.

I have uploaded a test version to (right-click this link and save as). This should be compatible with all versions of glibc down to V2.7. You should be able to just download and run this version without having to unzip it.

Dammit. Forget that. The installer works but SheetCam still won’t run. Back to the drawing board.

OK, let’s try that again. This version was built on Ubuntu 10.04. It should run on later distros as well. Right-click and save as. Note if it asks if you want to update, DON’T answer yes.

Les I tryed your revision and as you figured out it will load but will not run ,thanks so much for your work

The last one you posted won’t even load , if you right click it doesn’t give you the option to execute

If you right-click on the file and select ‘properties’ you should be able to set it as executable. That is an operating system function and has nothing to do with the contents of the file. Basically you are just giving yourself permission to run the file.

I got it to load and actually got it to run by opening it with another application which was Sheetcam tng out of recommended applications and seems to work except for the grid , the rulers show up but no matter what i try the grid won’t come in , i can deal with that i suppose , i called Candcnc and they are gonna send a linux master intall disc to see if that will help . Again thanks so much for the help. One other thing i really don’t think its right because it doesn’t show the sheetcam program icon like it used to

I tried both of the installs posted. I too could get them installed but could not get them to launch. I am excited that we got the install to work! Now the next step!

I posted both failure dumps through the launcher.

I didn’t get the dumps. What do you get when you try launching SheetCam from the command line?