Sharpen corners feature for plasma...

I recently cut a thick job on my plasma and it had lots of internal corners, these suffer as the plasma flame tail lags behind the nozzle which gives a sort of radius instead of a corner.

I asked about and one way of giving a big improvement was to manually draw the cut path, run sheet cam with no offset, and draw into the path a little extra in the corners…

Take a 90deg internal corner, the cut path would come down one side towards the corner, when it reaches the corner the cut path pulls away at 45deg by a set amount, then returns to the corner and continues on with the other edge of the corner.

A bit like a lead-out and instant lead-in diagonal to the corner.

I’m sure this can be added :wink:

Similar to the excellent way you can sharpen corners on the mill but the opposite direction.

Would it not be better to pause for a very short time on the corner to allow the tail to catch up? You could do that using an ‘on inside corners’ path rule. Use a code snippet with code something like this:

It might work, but what i think will happen is that while the tail catches up, the top will eat into the corner - you get a good base but spoil the top.

I will try it out though as soon as i can.

It also sounds a bit like going into “exact stop” mode on Mach3 which is generally not good.

I can’t get that to work properly.

If i have a snippet with G04 P0.3 in it, place that in the before corner box on an inside corners path rule, speed 100% and zero distance it gets ignored.

It does not work if you place it the after corner boxer either, BUT if you place it in the before corner box AND place something like a THC-off snippet in the after box it DOES trigger - but of course you get the THC off after the corner as well :frowning:

It also places the delay after a perpendicular lead-in - not good.

must be a better way??

I manually edited some code today to add a delay in the corners - it does not do what you expect :wink:

The tail of the flame stayed where it was and did not straighten up like it was expected. The delay then just caused a divot groove where the flame stopped moving and at the angle it was at as well.

Could you try manually editing the code to apply a pull back and see how well it works.

If i can figure out the code I will have a go :wink:


(not that I have a solution to your problem, but I thought I’d ask)

how thick are you cutting?
what are you cutting?
how fast are you cutting it?

Instead of stopping in the corner, have you thought about changing the feedrate to ~ 60% with a short lead in and out… kind of what you do for holes?

Alternatively… how have you drawn your inside corner?

Have you tried doing as I suggest, but applying a small radius, that way the top of the hole may get overburn, and the tail may catch up.

You may want to experiment how much slowing down the feedrate changes the thickness of the kerf… maybe by cutting circles at different feedrates or 90 deg corners (with a small radius).


I ran into this exact issue the other day. I was cutting my first Jeep fire pit out of 3/16, at Hypertheem book specs for my PM85 w/ 45 amp tip. When completed, the tabs would not seat into the slots completely, due to this “flared radius” on the inside (base) corners of the tab. I had to “finesse” the unit together with a mallet. :wink:

After that, I created and cut several coupons using just the tab area of the original drawing. I changed settings each time, looking at the results. I found that reducing the overall feed rate by 10% helped reduce the overall bevel to a level I like.

In addition, I created a code for the inside corner, which slowed the feed rate an additional 60%, .15 before the corner. Using this rule, I was able to cut coupons with a much reduced radius bevel/flare on the inside radius. The coupons were dropping into the same holes that required a mallet earlier.

Fwiw, I also had an arc rule in this cut ruleset. “Arcs with sharp inside corners”, or something like that, is what I called it. I understand that multiple rule codes in the same ruleset can cause issues. I made sure both rules in the set slowed the feed by the same amount, at the same distance before and after (.15). I hoed that if there was a conflict, the end result would be the same, as both rules did the same thing.

You shouldn’t have any issues with overlapping rules. If you have overlapping rules the one with the lowest feed rate wins.

Great to know! Thanks for clearing that up!