Rigid tapping issue

Have been using SC for years and love it. Good job Les!

I recently added a spindle encoder to my Centroid Acorn powered Enco mill retrofit so I could do rigid tapping.


I have got the machine set up and have successfully run the Centroid Intercon CAM to test the process and controls.

I am trying to create the code for a simple one hole test and can’t see to get the tapping portion to run. Simulator does not show it to work as well.

I am positive it is ME and not the software. Here are ths screens from the tool setup and the tapping operation:

Tempe, AZ USA

Are you getting a warning that no holes were found? If so, check your min hole size and max hole size. These have to be either side of the tapping marker circle diameter.

What post processor are you using?

No warnings at all. It posts fine. I am using the Centroid M400 post processor as I have been doing for a couple of years.

When I run the simulation it stops after the drilling cycle. Running the job in real time on the machine generates the same results. After the drilling cycle the job stops.

The job file is attached. I tried saving my tool set, but the forum would not allow it due to the extension which I changed to .txt

Mill Verde.txt (5.27 KB)
10 32 tap test.job (9.7 KB)

The job looks fine. I suspect your post doesn’t have the code for rigid tapping. Try the ‘Centroid Mill V2’ post. If that doesn’t work, send me a copy of your Centroid M400 post and a sample of tapping code generated by the Centroid Intercon CAM. I’ll modify the post to suit.

I assume if it does not “simulate”, i am wasting my time trying the G Code?

I tried both of the Centroid Mill Posts


Sim is working but as you only have one tapped hole you don’t see much. Try the G-code on your machine.