Problems with Linux command CNC after switching to new computer

I have been running Sheetcam and a Candcnc mp3600 THC on Linux for almost 2 years now. Everything was working great until I recently. I got a new laptop and this is where I run Sheetcam (separate from the Linux computer). After downloading the most recent version of Sheetcam to the new laptop and making some cuts I noticed a few weird things. Before I was able to use cut rules to turn on and off the THC for things like corners, curves, and holes where I wanted to slow down and / or turn the THC on and off no problem.

After the sheetcam update now every time I try to use cut rules I get a ton of problems with the torch height in the spots where sheetcam is telling Linux to turn the THC off. Mostly the torch dives towards or into the material when the rules are applied. Cut height is set to .06 in sheetcam but sometimes when the THC get turned off it will run at a height of like .02 or actually drive into the material.

It runs pretty good with no cut rules, the THC on, volts set proper and VAD on but still dives a lot on images with lots of turns. This really sucks on things like 1/4" plate where I would normally slow way down in corners to make them nice and crisp and things like detailed images.
I also noticed it pauses way worse at the end of a cut when I use the THC off before end of cut rule. It did not do that before the update.

The only thing I changed was sheetcam on my laptop. I did not change anything with the Linux computer running the actual CNC machine.
What is going on here??
Is it possible that the newer version of sheetcam is cauing problems with the linux system?
Is it possible to go backwards versions in sheetcam to see if this fixes the problem?

Can you run a gcode on the old computer and the new computer and compare them? Are you using the exact same post processor as before?

Over in the CandCNC forum they’ve had a thread on this. Basically it says with CommandCNC you don’t need to use any cut rules as CommandCNC knows when to slowdown for corners and holes by itself. The thread went on to say that cut rules will fight with CommandCNC and give you all kinds of weird problems. I’ve been running CommandCNC for quite some time now and have never had a need for any cut rules.


Do you have some old g-code files that use rules and work correctly? If so post one of those here with a newer one that doesn’t work. I’ll take a look and see if I can spot anything obvious.

The NAME of the cut rules may be the same, but the CODE in the cut rules can be different between Windows/Mach and Linux. I went from Mach to CommandCNC as well. Initially, I didn’t use any rules at all, but I’ve slowly started adding them back in. Torch off before end, slowdowns at sharp corners, etc.

I forget where, but somewhere on the CandCNC site (and possibly in the documentation for CommandCNC) is a chart showing some of the changes in code required between the Windows/Mach setup, and the Linux/CommandCNC setup.

If you are going to do prep-work in Windows (as I do) but run the machine with Linux (as I do), you need to have the same rules and post-processors loaded in BOTH sides. This means loading the LINUX based rules and LINUX post and using them in Windows Sheetcam.

Great thank you! this is exactly the type of info I was looking for :slight_smile: I am going to look into this further!

There are certain circumstances where I absolutely need cut rules.

Ok guys, I think I got it fixed. The code that was being generated from the tool set for THC on/off was wrong. I figured it out by re-reading the Candcnc manual for Sheetcam Linux setup and by comparing the old codes I had to the new ones.

I ran one test and it seems like its back to normal. I will let you know if I have any other issues.

Thank you very much for everyones suggestions! It really helped me figure out what I was missing :slight_smile: