Problem installing SheetCam on Raspberry PI4 (Buster OS)

Hello
I’m trying to install SheetCam 32 or 64 bit linux version as described on download page.
The OS’ is Debian 10 Buster 64bit running on Raspberry PI4
First I tried to check permissions tab and make sure ‘execute’ is turned on and then I double click on and nothing happens.
Second attempt was to unzip and execute run-sheetcam from data folder and nothing happens.
Is this a issue with the combination of Raspberry PI4 and 64 bit arm architecture?

The Linux version only runs on X86 architecture. It won’t run on Arm.

Any chance in the future to have a SheetCam arm32 or arm64 application?

Bugger, just read this post. I saw some time back that there was a Linuix version so I pressed on, bought a PI , got it all running over a few days and tried to run Sheetcam only to find out it doesn’t work.

Any advance on a ARM version ?

PS I got a PI4 with 8GB, a 460 GB SSD USB drive and used Raspberry PI Desktop 64 bit image on it. The system flies. Very impressed.

I’ve got a new Machining center and wanted to add a PC to the machine for G-Coding. I was hoping to use the PI and then I would have replaced my 2 other ageing XP machines on my other 2 CNC machines with this upgrade.

But alas not sure where to go from here.

Cheers Wallace

I’m sorry but it is unlikely that I will be making a Pi version. Creating a Linux release is a significant amount of work and there are very few Pi users who would use it. Combine that with the fact that the Linux releases generally require quite a bit more support and it simply is not worth my while.

what does sheetcam require from x86 architecture that it does not like about arm?

I ask this dopy question as I’ve got sheetcam (windows) to run on playonlinux …

I’ve also been running sheetcam Linux on Debian bullseye and buster.

is it not just a case of missing dependencies on RPI that you need to add to get it to work.

what os have you installed on RPI and what version?

Arm and x86 are not binary compatible. It’s not a case of a few missing dependencies, everything needs to be recompiled to run on Arm.
When you say you have the Windows version running on PlayOnLinux I assume that is on an x86 machine. I believe a few people have managed to get Wine/PlayOnLinux to run on a Pi by basically running it inside an x86 emulator. Emulation is very slow so the performace would be horrible.