Priority for path rules

Hi Les!
I use a wonderful SheetCamTNG feature - the path rules for plasma cutting.
All work fine! But in any case I have the problem.
For example I have 2 path rules - On AllCorner and Before End for THC ON/OFF control.
Before end SheetCam set the THCOFF action point. But if there is then a corner, then “On All Corner” rule is triggered and the THC control can be switched ON again.
This is fragment of the program

N1460 G01 X154.9204 Y305.5000 F3400
N1470 E5P1 (THCOFF) (Before end)
N1480 G01 X164.9819 Y305.5000 F3400
N1490 G02 X165.0400 Y305.4966 I164.9819 J305.0000 F3400.0
N1500 G01 X165.0605 Y305.4942 F3400
N1510 G02 X165.3560 Y305.3512 I165.0024 J304.9976 F3400.0
N1520 G01 X166.0631 Y304.6440 F3400
N1530 E5P0 (THCON) (On all corners)
N1540 G01 X168.5557 Y302.1514 F3400
N1550 M05

Can I set the highest priority for the “Before End” rule?
Can I do it, after triggering “Before End” rule others rules were blocked until the end of the cut? I hope it is possible.
Thanks!!!

Hmm, I see the problem. I put quite a bit of time into making the rules automatically sort out overlaps and conflicts but I didn’t think of this scenario. The next development release will fix this. I will try to get it out in the next week or so.

Thanks!
We look forward to the update!

Hello Les!
I have another question about rules.
I have to cutting one hole. Diameter 6 mm.
I have enabled rule for hole less than 30 mm and rule On all corners to disable THC. But when I run postprocessor corners rule applies to hole - this is incorrect.
If I am disable rule for corners, code generated correctly.
Why Corner rule applies to hole?
Thank you!

I am forgot to attach job file.

The rules are being applied correctly. Due to the limited space in that circle the lead in has been tipped slightly. There is more than 10 degrees between the end of the leadin and the start of the circle so your ‘on corners’ rule is being triggered. There are two possible solutions here:

  1. Increase the angle in your corners rule
  2. Use the development version of SheetCam and use the ‘Start at the centre of circles’ option in the plasma cut operation. When you start at the centre of a circle the leadin meets the circle perfectly.

By the way it is better to start a new thread rather than resurrect a year old thread. It is easier for others to find if they have similar issues.

Thank you very mach for fast answer and help! I will try to make this changes.
On the next time I will start new thread.