price cnc AVNC10

Hi all …

new here and new to the plasma table world , i have built my ow table , from scratch , and now after 10 weeks its finally finished and starting to cut , i trialed the sheetcam software some week ago to get the feel for it on my laptop, and found it fairly easy to lean , and so I bought a licensed copy as well as a full mach 3 license …in the last week ive added a floating head and a THC … this is where the brain pain really kicks in … my z axis was sending the torch up and down all over the place , i decided to have a play with the post processing provided by price cnc with the AVHC10, and edit some g code … and have managed to get the torch to go up and down to roughly the right heights during and between cuts with the THC off , with it on it seems to be miss-behaving a bit , but im working through it … im just wondering if anyone else has had any experiences , good or bad with the price cnc THC and the post processor that comes with it ?.. any advice or tweeks ?.. ive adjusted some height values in there to get something consistent from cut to cut , but ive still a way to go to find the pot of gold at the end of the cnc rainbow

after some hours making changes , i now have the torch moving correctly most of the time without THC , occasionally it will do 3 or 4 cuts then for no apparent reason go up instead of going down to find probe switch …then it resets as zero , and goes up for its pierce and cut adjustments leaving the torch about 2 inches above where it should be ?.. also , when it is working right , if i start off with thc enabled it goes to start makes the pierce then just stalls and wont move … starting thc after it has made its first cut it will operate correctly , but it will stall on pierce of 2nd cut again … im at a loss as to why this is happening other than its somewhere in either my sheetcam tools , post processing or less likely maybe a mach3 setting … any ideas anyone ?

It sounds like your accelerations settings may be too high. I would guess that sudden jump when THC engages is making teh Z axis stall.

is your z axis getting caught on the cable making it think its hit the switch in the floating head
i could send you a copy of our post (i make the rtech tables)

well after another few days of tinkering and almost losing my s**t a couple of times , i narrowed it down to post processing that was doing me in … the Z definitely wasnt getting caught on the material or anything , i watched it closely to confirm , and the motor tuning is as good as i can get it , not super fast , but nice and smooth strong movement so i didnt think it was that either … so i ditched the price cnc processor and tried the standard mach3 plasma PP … guess what , normal working behavior now , only this pp doesnt allow for a zero reset of the Z probe switch after each cut … but it does lift , move , touch off , then do pierce and cut height adjustments … i can live without the z axis being zero’d each cut , and I made some successful pieces yesterday with the THC working well ! there is another PP i downloaded but havent tried yet , a guy made a youtube video of his AVHC10 working well and posted a link to the PP he was using .if you wouldnt mind sending the PP you described id be keen to give it a try …
thanks for your thoughts on the problem i was having guys … the only other problem im having now is sheetcam crashes every time i close it … ive tried to uninstal it then reinstal it , but uninstalling doesnt remove all of it , so when i reinstal it again , all previous settings are still there , and the crash problem as well… :open_mouth:

I have seen the crashing on close issue a few times. It usually turns out to be a display driver issue. Intel display drivers in particular seen to give trouble. Try updating your display driver. If that doesn’t help, try the development version of SheetCam. It uses slightly different graphics which can help on some machines.

Thinking of your touch-off issues, I think Rob might be on top something. A damaged cable or switch could cause symptoms like this. A normal probing cycle will move down until the switch trips then back off until it releases. If it thinks the switch is already tripped at the start of the cycle it will try to back off the switch instead of moving down.

Thanks Les , i’ll try updating graphics driver as im still having the crash problem , can i aslo ask if you have a special way to delete a post processor from the list , ive removed the price p.p several times and ways , but its always back the next time i start sheetcam up and its back to being the default pp … maybe thats casused by the crashing problem as it doesnt shut down correctly and therefore doesnt save my new settings ? anyway , a[art from these couple of little computer glitches , im having SHEET loads of fun with sheetcam now that im getting used to working it :laughing: … cheers David

i have replaced the micro switch once already , and testing it in mach3 on a slow jog down and up , it works everytime the way it should ( while im testing it thats is ) intermittent problems are always the hardest to track down … :unamused:

That sounds like SheetCam is crashing before it can save it’s settings. Saving the settings is pretty much the last thing it does.