PlasmaRotary Mach3 post problems?

I’ve been using the Plasma Rotary Mach 3 post for a tube cutter I had built, It was working well until something happened in either mach or sheetcam. I honesty don’t know what happened but I can no longer get the tube cutter to work, When I load a TAP file and hit run the rotary spins around forever until it hits the coordinates in line N0100… I found a old TAP file I had of a cut file that i used and worked before I tested it and it works just fine… here is some screen shota of one that works and one that doesn’t work I highlighted the code… hopefully someone can help me
dosnt work.jpg

I might have fixed it, or figured it out

In the post "number of units per revolution
Units per rev = 360

I changed the number on Units per rev to 1
Everything seems normal now

I wounder if i opened up a older job and saved the currant default settings by mistake…

I was going to say it looks like maybe your rotary axis got changed from linear to angular somehow. I guess that’s kind of what happened. Glad you figured it out.