Plasma - decrease feedrate for cutting holes.

Typically when cutting small holes with plasma the feedrate must be reduced to about 60% of the normal speed to improve cut quality. The THC should also be switched off to prevent the tip from diving due to the lower speed. It would be great to have an option to automatically reduce feedrate by a certain percentage when cutting holes under a certain size, and to send MACH THC on/off commands at the proper times.

The way I do it now is move all my holes to a different layer and use a separate operation for the holes.

To a certain extent this can be done in the post processor. Have a look at the MP1000-THC-scriber post. It probably does most of what you want.


Great, can’t wait to try it out. Thanks!

I ran a few tests and this seems to do the trick. Thanks again for the quick reply. I did find an error in the post, the following comment is incorrect or at least misleading:

--Put your switch offset value here in MILLIMETRES
switchOffset = 1.5

With my units set to inches I have to enter this value in inches.

I also tried TNG for the first time. I cannot get lead-ins/outs and wiggle pierce to work, is that a limitation of an unlicensed version?

I’ll fix the switch offset. it should be in millimetres.

Leadins/leadouts should work. Can yousend em a job file to look at.

Leadins/outs do work, I was using a newly configured tool and I had the length set to 0" :blush:

The MP1000-THC-scriber post file woks as expected for reducing feedrate on small arcs.

The THC on/off code is causing some problems. It inserts the thcon/thcoff command in the correct places, but it causes Mach to pause briefly for each command. This isn’t really a problem for holes, but for a square where the offset toolpath generates small arcs on the corners, or any shape that is a combination of arcs and lines, it pauses twice at each corner. I think this is a limitation of Mach, stopping travel as it waits for the THC on/off macro to run. I’m using a one-line macro to use an M code to execute a button press, I don’t know how to make it any simpler.

For now I’ve just left the thcon/thcoff commands nil. Has anyone been able to get this to work?

The THC on/off pause is a known problem in Mach. This is why I didn’t really done much about it before.

Hi, I go to open sheetcam and getting this message(This vcarve plugin has expired. You must install latest version to continue using it.) I tried updating, but it said no updates found. I am using windows 7 with sheetcam version 4.1.30 Any help greatly appreciated.

Is your clock set correctly? If your computer’s clock is out you can get this message. If you don’t use teh V carve plugin go to Options->plugin options->Vcarve2 and make sure ‘Enabled’ is turned off.

I down loaded the PDF instruction book but it is confusing because it covers both milling and jet cutting and I only need the jet cutting part for plasma cnc and I am not sure which page to ignore and which is important.

Have a look at the training series from Arclight Dynamics It starts about half way down the page.

By the way, it is better to start a new topic than try to re-use an old one. That way it is easier for people to search the archives.