Oxy/Fuel post

In the program below, I have removed all Z moves, both rapid and feed rate. If you look at line 90 there is a G00. This is where a Z rapid would normally be but since I removed that line in the post, the Z move does not appear. Is there a way to make the entire line go away?

N0000 (Filename: oxy test.tap)
N0010 (Post processor: TruCutCNC - OxyFuel.scpost)
N0020 (Date: 17/09/2011)
N0030 G20 (Units: Inches)
N0040 G53 G90 G40 G91.1 M7 M1100
N0050 F1
N0070 (Process: Outside Offset, OUTSIDE, T113: Oxy/Fuel)
N0080 M06 T113 (Oxy/Fuel)
N0090 G00
N0100 G00 X-0.2661 Y2.7601
N0110 G04 P5
N0120 M1102
N0130 G03 X0.0603 Y2.9168 I0.0849 J0.2415 F12.0
N0140 G01 X0.8683 Y5.2152 F12
N0150 G02 X1.1998 Y5.5416 I0.4966 J-0.1729 F12.0
N0160 G01 X2.4468 Y5.9495 F12
N0170 G02 X3.5214 Y5.9495 I0.5373 J-1.6410 F12.0
N0180 G01 X4.7685 Y5.5416 F12
N0190 G02 X5.1000 Y5.2152 I-0.1650 J-0.4992 F12.0
N0200 G01 X5.8772 Y3.0043 F12
N0210 G02 X5.9362 Y2.6580 I-0.9853 J-0.3462 F12.0
N0220 G01 Y0.2814 F12
N0230 G02 X5.6604 Y0.0013 I-0.2781 J-0.0021 F12.0
N0240 G01 X0.2771 F12
N0250 G02 X0.0013 Y0.2814 I0.0022 J0.2781 F12.0
N0260 G01 Y2.5705 F12
N0270 G02 X0.0603 Y2.9168 I1.0444 J0.0001 F12.0
N0280 G03 X-0.0963 Y3.2432 I-0.2415 J0.0849
N0290 M1103
N0300 G00
N0310 G00 X0 Y0
N0320 M05 M30

OK…Made it go away by setting rapid clearance to 0, but I’d rather make a change to the post so rapid clearance can be left alone. Setting it back for a plasma part after changing it to 0 for a flame cut part is just one more thing to forget. :slight_smile:

That line is harmless but if you want to get rid of it, put this line right at the beginning of your OnRapid()

if&#40;math.hypot&#40;currentX - endX, currentY - endY&#41; < 0.001&#41; then return end