new to sheetcam, need help

Hello everyone,

I got through everything, got my part nested and ready to cut. Set up my machine 3040 cnc mill using Mach3, post processed my final product without an issue. It ran fine in simulation. However when I load it into Mach3, it gives me an error of having “I word for Arc in the X,Y, plane.”

What am I missing? I know there has to be something that I have to change to make it not put the plasma info in the code.

Thank you for the help,

welcome and greetings Bartman.
I’ve had a similar error due to mistakenly coding in OnArc() function of the .scpost a conditional output of the “I” and “J” words in the G2/G3 grbl arc commands, when I believe that both I and J are required. The function post.ModalNumber() will conditionally refrain from output the resulting text string, in this case the “I” word concatenated with a number, IF the exact same text string was LAST output. So I changed the ModalNumber() function call to a NonModalNumber() function, which ALWAYS will output the resulting text string. Again, this is in OnArc() function.

But to be sure for more diag and help, post your .scpost file, the sheetcam .job file, and the gcode file in this thread as attachments (not inline) if that doesn’t solve the problem.

Thank you my friend, I will screen shot the error msg and attach the NC code I’m trying to run.

I have everything set for milling, I just don’t know what to change to make it work.

I’m a pretty sharp guy, built dies and molds for 26 years, but this one has me stumped. I draw in solidworks and just use the sheetcam for nesting many of the same parts on .135 in thick pressed paper gasket material. 15 x 15in I can cut 86 pics. If I can get it to run…lol

Thanks again…will post in a few

Error Message says in Mach 3 says, “I word given for arc in YZ plane line 16”

Error Message says in Mach 3 says, “I word given for arc in YZ plane line 16”

YZ plane suggests your controller received a G19 stmt somewhere, but its not in the .tap file attached above. But then neither is a G17 stmt, which puts the controller in XY plane, which should be the default. So perhaps before running the .tap the controller was left in a G19 state from a previous job ? Edit the .tap and change this line to include a G17, like so…
N0050 G40 G90 G91.1 G17

Your .tap file ran on my grbl v1.1i controller in $C (Check) mode, so no machine motion takes place. I had to remove the two tool stmts though, which should not effect the error you were getting. And the .tap does fail if I force my controller to a G19 state prior.

Thank you my friend, I will give it a try and let you know how it goes.

That worked out great bLou! Thank you for the assistance my friend, very much appreciated!

you’re welcome, glad to help

I cleared everything and even started a new job and couldn’t get it to build it with the G17 in the G code. As long as I know I have to exit it, I’m fine with it, but seems it should do it on its own.

G17 (XY plane) should be the controller default. Perhaps Mach3 has a setting for this ? I don’t know Mach.
You could also edit the .scpost and add G17 in the OnInit() function where G90 and G91.1 are set, on the same line.

I got it so it posts and will run without adding the G17 code now.

Now it will run to high, it post’s to far above specified Z height. Starts .700 high not .200 and rapid down to .100 then slow to Z zero then begin cut and .040 ramp to depth of .145.

I’ve been on it since 4:30 am…lol

Time for a break

Now it will run to high, it post’s to far above specified Z height. Starts .700 high not .200 and rapid down to .100 then slow to Z zero then begin cut and .040 ramp to depth of .145.

That shouldn’t be related to G17 stmt, different problem I believe.
Sounds like the “Plunge safety clearance” may have gotten changed or zero.

These are my typical settings in Options->Job menu…

In the .tap file from yesterday, you had this gcode…
N0350 G00 Z0.9500 – this is motion to Rapid clearance value
N0360 X2.2094 Y0.8913
N0370 Z0.7500 – motion to Plunge safety clearance
N0380 G01 Z0.7100 F20.937 – motion and feedrate to plunge to cut depth
N0390 G03 X2.2094 Y0.8913 I0.0032 J0.0032 F30.937 – shape cutting and feedrate

It should be .200, rapid to .100, then begin cut at Z 0, cut .040 set cuts until depth of .145

I’ve set the material thickness at .145

Everything in the tool info is correct as well as the material file.

I will look at the setting like you posted just will put something in there to get it to cut.

Again I know it’s something simple that I’m overlooking…lol

Thank you again for your assistance

Figured it out, I had .750 offset for my cutter length. I thought that was fir overall length of cutter hangout. Now I know better…lol

I using shhetcam for my Plasma table with a water pan. I know how too use the pause feature in sheet cam to pause after cut. Currently when it pauses the Z axis stays at cut height during the pause and churms the water below. That can cause a big mess at times. Is there away to have the torch lift or lift and move slightly before the pause?

This can be done with a post modification. What post are you using?

Langmuire systems Fire Control
FireControl-v1.6.scpost (5 KB)

In SheetCam go to Options->machine->post processor and click on the ‘Edit post’ button.
Look for function OnPenUp() near the end of the file. Replace the function with this version:

function OnPenUp()
   ihs = pierceHeight ~= 0 and cutHeight ~= 0 --enable IHS if both pierce and cut are non-zero
   post.Text ("H0\n") -- thc OFF, Machine in control of Z
   post.Text ("M5\n")
   if (ihs) then
      post.TextDirect ("G0 Z" .. post.FormatNumber(25.4 * scale, "0.0##") .. "\n") -- Z to rapid height
   if (endDelay > 0) then
      post.Text ("G4 P")
      post.Number (endDelay,"0.###")