Need an updated UCCNC Plasma Post Processor

Is there a UCCNC Post Processor for Plasma with settings for G31 touch off and absolutely no THC functionality in it? I want to write my own sheetcam path rules to control the THC better. I’ve tried disabling THC in a few post processors using the editor and the recommended “nil” entry, but, I’m not having any luck with that. It might be some old nil comments leftover from people rewriting the code or it could be that I am not a programmer.

In summary, UCCNC + Plasma + G31 touch off = my ideal post processor. No THC at all.

All the best,


The ‘UCCNC plasma’ post supplied with SheetCam should fit the bill. It only uses M31 as a probing cycle.

Thanks Les,

I’ll take a closer look at that one. I had looked into it before, but didn’t notice the G31 way down in there.

All the best,

Scott Meer

I tried the UCCNC Plasma post processor and I’m still having issues. M205 and M206 are still being added throughout the g-code. See below:

N0010 (Filename: Test - TEST 4 inch UCCNC Plasma v1.tap)
N0020 (Post processor: UCCNC plasma.scpost)
N0030 (Date: 7/22/2021)
N0040 G21 (Units: Metric)
N0050 G53 G90 G91.1 G40
N0060 F1
N0070 S500
N0080 (Part: Test - Scott Meer 4 inch)
N0090 (Operation: Outside Offset, Layer_0, T9: 16 Gauge Fine Cut Metric 40 Amps)
N0100 M06 T9 F3810.0 (16 Gauge Fine Cut Metric 40 Amps)
N0110 G00 Z50.8000
N0120 X0.0000 Y0.0000
N0130 M31
N0140 Z2.2860
N0150 M03
N0160 G04 P0.4
N0170 G01 Z1.5240 F3050.0
N0180 M206; THC OFF (On all corners)
N0190 F2135.0
N0200 X-8.4923 Y8.4924 F2667.0
N0210 G03 X-10.7425 Y-5.3701 I8.4924 J-8.4924
N0220 M205; THC ON (On all corners)
N0230 X-7.7566 Y9.1692 I10.7425 J5.3701 F3810.0
N0240 M206; THC OFF (Before end)
N0250 X-8.4923 Y8.4924 I7.7566 J-9.1692
N0260 X-8.6326 Y8.3498 I8.4924 J-8.4924
N0270 M05
N0280 G04 P0.5
N0290 G00 Z50.8000
N0300 X-12.1426 Y16.8371
N0310 M31
N0320 Z2.2860
N0330 M03
N0340 G04 P0.4
N0350 G01 Z1.5240 F3050.0
N0360 M206; THC OFF (On start)
N0370 X-12.3538 Y17.5045 F2667.0
N0380 X-13.6696 Y18.5583
N0390 G02 X-13.8329 Y18.7468 I0.4313 J0.5386
N0400 G01 X-14.7782 Y20.3522
N0410 G02 X-14.8736 Y20.7023 I0.5946 J0.3501
N0420 G01 Y33.8956
N0430 X-18.5709 Y31.9075
N0440 X-18.5486 Y19.9777
N0450 X-16.8989 Y17.2563
N0460 X-13.7548 Y15.4146
N0470 X-7.8912 Y18.4121
N0480 X-8.0190 Y18.6858
N0490 X-11.1332 Y17.0558
N0500 G02 X-11.8845 Y17.1286 I-0.3200 J0.6113
N0510 G01 X-12.3538 Y17.5045
N0520 X-12.5099 Y17.6295
N0530 M205; THC ON (On all corners)
N0540 M05

You have an ‘on all corners’ rule outputting the m205/m206 codes.

I must have something going on I don’t understand. I have path rules set to none. Where else would this be coming from?

Edit your path rules. Do you have a rule set selected in ‘Always apply rule set’?

Les, you are friggin awesome! That was it! Fixed. Its been driving me crazy. One little checkbox. Thank you. You’re the best.