mach3 on drive d scanything not adding pluggin. How can I wo

Trying to use the scanything program but ran into the issue of the pluggin not showing in the config menu of mach3. I searched here and found one thread about the issue. Ok got my computer this way they had made drive d: the main drive not c:. So mach3 is installed in that directory. The scanything pluggin is not shiwing in the config menu. So the thread Les says that scanything looks for mach3 to be on c: drive only. I looked into renaiming the partions on my drive but that will not work when the partion I am renaiming contains the operating system. No way I would flush the entire thing and start over that would be a real pain in the butt. So how or is there a way for me to get the scanything software to find the mach3 program. I tried manually puting all the files into mach 3 no luck. What can I do please?

Thanks for the help! Great software and enjoy using sheetcam a bunch just would like to try this scanything.

Do you have a C drive? For instance if you plug in a thumb drive does it appear as C?

Yes it does have c. It is A partition on the main hard drive. It has windiws xp recovery on it. Whats weird us there is a mach 3 folder there thats a duplicate to the one one partition d. But mach3 and scanything and every other program including windows xp are on partition D. But the answer is yes there is a partition C.

The plugin will have been installed on the copy on your C drive. If you look in c:\mach3\plugins you should see SheetCamRemote.dll. Copy it ot the same place on your D drive.

Awesome I wil go give it a shot! Will let you know how it goes. Thank you Les!

Great news! I got it working. Nuts though. I went to the mach3 plugin folder and there was not the sheetcamremote.dll file anywhere C or D nothing. Did a system search which returned no results for that dll on the entire computer. So I went to my windows 10 computer. Entirely different computer hooked to the net my regular machine and installed mach3 then installed scanything and opened the mach up config and plugins and there was the scanything listed. So it worked on that machine why not the old xp unit hooked to my cnc.
Then I did this I grabbed the .dll from the folder on the win 10 computer and copied it onto a jump drive. Brought it to the shop and pasted it in the pluggin folder in mach3 on drive D:. Then opened mach 3 and there it was in the config list. I checked it green closed config opened scanything and it still says machine NOT connected. So I closed everything out and restarted windows. Opened mach3 to verify it was enabled in the config tab, then opened scanything and wooohooo MACHINE CONNECTED! Now everything works it jogs perfect.

So why xp would not load the sheetcanremote.dll I do not know. But it works now so thanks very much for pointing me to the correct dll file and sending me on a path that worked out.
Have a great day!

Now I need a better camera this one wont calibrate. So will get one coming now that I know it is going to work.

It’s important that the camera is oriented properly. When you move the camera one direction, the view you see on your computer moves the same way. (I hope that makes sense). I had trouble at first getting my camera to calibrate, then discovered that you have to have the camera rotated the right direction, and it calibrated right up.


Yes after poking around threads I seen it has to be correctly orientated for sure. But the camera is a $3.00 special off ebay. So I think my issue is there. I have the dot on screen then click calibrate. It slowly moves right past the black dot and then continues till the dot hits the edge of the screen or video window then stops tracking although in the box it still says calibrating. So why it just drifts right on past the dot and never locks on I do not know. Must be the camera. I tried up and down on z for different focal lengths no difference. Tried lots of different lights. Nothing changes it circles the dot with the blue ring and the green ring goes right past it and drifts to the edge then bothe blue and green circles dissappear?

That sounds more like an alignment or motion problem than the camera. Are you using the parallel port? Some USB and Ethernet I/O boards cause problems. To check camera alignment jog X+. The image should move left. Next jog Y+. The image should move down.

Lol so you guys are going to crack up. Like I say only a week or so I have had it running so learning big time. Well I had my home set to the left rear of my table and set mach3 for that to happen. I been trying to cut some parts 2d stuff with no text or anything for reference. For some reason it was cutting g41 and g42 - inside or outside swapped! Everything that should be an inside cut was outside and the other way around as well. So Last night I gave up and tried a name plaque for my daughter with vcarve pro I just bought got installed and walked through some vector training videos. I did everthing then went to cut and my machine cuts the text in a mirrored image! So I walked away. I needed a break from this thing. While explaining to my wife what was happening and drawing on paper I realized on the mach3 screen it was placing the parts lower right or rear right corner. I have my table set for left rear so those setting do not transfer over on screen so light bulb now flickering I went back and opened homing and limits and flipped my Y axis and settings and saved. Fired up the reference home and it set to the rear right. I then ran gcode and succes! Cutting properly! So light bulb now glowing I said this is why scanything would not calibrate. So I opened scany and it calibrated is a few senconds and made my first trace no problem. Camera is holding 30 to 34 frames a sec and it does great.

So long story short if you have a problem do not be afraid to ask around for help. And most of all dont give up success may be one click away!
Thanks again Les for the video on you tube how to use it and thanks for helping me here.

It’s an easy mistake to make, especially if you have a moving table machine. That is why I keep asking if the display if the display moves correctly in Scanything when you jog.