Linux noob trying to install SheetCam 32 bit version

First off I would just like to introduce myself. I have been building a CNC plasma table for the last six months and I am just about to the point of getting it to move under it’s own power. I recently purchased a CandCNC electronics package along with a license for SheetCam. UPS says it should all be delivered later this week. :smiley: I ordered the package that runs on a custom version of LinuxCNC on a pre-configured Linux computer.

Wanting to know more about Linux, I have been playing with LinuxCNC on an old computer that I had laying around. Here is what I have done so far:

  1. Installed LinuxCNC using the Live Install CD image from their website with Debian Wheezy
  2. I installed all of the updates using the update manager
  3. I installed Inkscape using the Synaptic Package Manager
  4. I downloaded the SheetCAM TNG for Linux 32-bit version
  5. I set the permission on the file to ‘Run as an executable’ and tried to run it but with no luck
  6. I copied the SheetCAM install file into the documents folder and unzipped it into a directory called sheetcam. I navigated to the data folder and tried to execute the ‘run-sheetcam’ file but with no luck.

Is there something that I am missing why I can’t get the program to install?

I’m looking forward to getting my table running and I am sure I will have some questions, so I’m sure that this won’t be my only post. :sunglasses:

Any help would be appreciated.


  • Steve

LinuxCNC uses a fairly old version of Ubuntu which won’t run that build of SheetCam. I am hoping to get an updated version out in the next few days.

Thanks! It’s good to know that I am not crazy.

I will keep an eye out for your updated version.

In the meantime, would it help if I installed LinuxCNC manually with Ubuntu Precise or Ubuntu Lucid instead of using the live install image (Debian Wheezy)? Will SheetCAM run on Precise or Lucid?

I did a little reading and searching on your forum today and found where you recommended to someone to try running the Windows version of SheetCAM using Wine. Would this be better to try rather than using Precise or Lucid?

All of this is just to give me a little bit of practice using Inkscape/SheetCAM/LinuxCNC before I get the electronics up and running on my table sometime in the next couple months.

I built a ‘micro-mill’ out of DVD steppers and have been making sure I understand how to set-up the motors, calibrate axes, translate DXF into g-code, etc.


  • Steve

I run Windows SheetCAM on Ubuntu 14.04 (and also tried on Debian, too) using Wine. Other than a little display delay, I think SheetCam works for the most part. SheetCam does die when I try to change printing properties as the preview is not right, but it does print correctly so all is good.

LinuxCNC may have updated not too long ago, but their v.2.7.x live disc is based on Debian Wheezy which may not be the latest, but one away…? I think CandCNC is borrowing LinuxCNC’s v.2.7.x for their item.


I think you are correct which is why I was surprised that SheetCAM wouldn’t install. It could be that CandCNC and SheetCAM worked together for a special version for the CandCNC hardware?!?

The current 32 bit version was built to run on the CandCNC setup, which apparently uses a later version of Linux.

Which path would give me the best chance of success for running SheetCAM along with LinuxCNC.

  1. Ubuntu Precise
  2. Ubuntu Lucid
  3. Wine on Wheezy/Precise/Lucid


Wine is pretty much guaranteed to work on all platforms. I am working on a version that will hopefully work on a wider range of Linux distributions.

OK Thanks :sunglasses:

Hi, I have also built my own hobby cnc plasma table and now i am searching good g code program.

Is there also 180 lines evaluation limit on sheetcam´s linux version? In the does not read the red note of limited evaluation version. I downloaded and installed sheetcam linux version to ubuntu but when i try to make longer program i got red evaluation limit reached error.

Is there some mistake or is this program just not free for linux?

It has the same evaluation limit. I’ll email you a 30 day license so you can have a play without the code limitation.

Maybe I just wasn’t meant to install SheetCAM on this computer… LOL

I installed Wine, installed the stable version of SheetCAM which seemed to go flawlessly like it was installed on a Windows computer, it even made a desktop icon.

Try to execute the desktop icon and nothing happens :frowning:

Try running SheetCam from a terminal. Something similar to:

wine /home/[YOUR_LOGIN_NAME]/.wine/dosdevices/c:/Program\ Files/SheetCam\ TNG\ Development/SheetCam\ TNG\ Development.exe

Modify that for your setup (not sure if you installed the development version or not). The terminal may show what the problem is. You may need to install a module via winetricks, but that’s just a guess.


Here is what I get in a terminal window

SheetCam\ TNG.exe
steve@CNC:~/.wine/drive_c/Program Files/SheetCam TNG$ wine SheetCam\ TNG.exe
WARNING: gnome-keyring:: couldn't connect to: /home/steve/.cache/keyring-KGTsX3/pkcs11: No such file or directory
fixme:msvcp90:numpunct_wchar_ctor_refs (0x166538 0) stub
fixme:msvcp90:locale_classic stub
err:module:attach_process_dlls "CamLib.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\Program Files\\SheetCam TNG\\SheetCam TNG.exe" failed, status c0000005

This is what I did with that error:

In a terminal, run “sudo apt-get install winetricks”. After that installs, run “winetricks”. Select the default wineprefix. Select “Install a Windows DLL or component”. Look for the package “vcrun2008” and select OK.

That should take care of it. At least it did for me.

It appears that I am not good at following directions… LOL

I saw on the download page where it said:

"If you are installing on a computer without Internet access, the installer may ask you to install this Microsoft update: vcredist_x86_vc2009.exe. "

But since I was installing on Linux and with internet access, i didn’t think I needed this.

I downloaded and installed vcredist_x86_vc2009.exe and now everything runs.

Thank you PK and Les for your help!