installing a different post processor?

Hi everyone! I have been given part of a plasma table and am building the rest. I have a problem and a question. When I run the post processor I get warning about g code error near line 11 G04 P1.

As I am using Linuxcnc I would like to change from the current listed ANCA 2000 to EMC Plasma as the post processor under options in Sheetcam.

How do I install this? I have tried to select it in the post processor tab but it always returns to ANCA.

Thank you all.

What version of SheetCam are you using? From your description it sounds like you are using the very old SheetCam Standard rather than SheetCam TNG.

The issue is a permissions problem. Later version of Windows don’t allow normal users to change files in ‘program files’. The old SheetCam was developed when the recommended practice was to store settings in program files so now it can’t save it’s settings. If you right-click on the SheetCam shortcut and select ‘run as administrator’ you will be able to save your settings.

Les, thank you for the reply. I am using 3.1.17. The friend that gave me some table parts also gave me his computer. The program was in it already, I thought it would be a good place to start learning.

I am not certain that changing the postprocessor will solve my problem, I think it might.

Time to upgrade!

Hi Les.

I should probably not be allowed a computer…

I uninstalled the sheetcam and downloaded the latest for Linux. Clicking did nothing at all, after some looking around I found the thread you wrote on using a documents folder and the terminal window. Still nothing.

I am attempting to upgrade Linux I have version 10.04 Lucid Lynx…as I said, I should not be allowed a computer!

Ubuntu 10.04 is a bit too old to run the latest SheetCam release. One problem with trying to support different version of Linux is that they keep changing things so I have to keep updating my release to keep up. This breaks compatibility with older versions of Linux. Unfortunately there isn’t a lot I can do about this.

IMHO compatibility is one of the reasons why Linux isn’t as popular as it should be. Few commercial software vendors are willing to enter the compatibility minefield of Linux. Windows on the other hand has excellent backwards compatibility Software that was written 15 years ago will still run quite happily on the latest Windows release.

Try installing Wine (you will find it in your package manager). That will let you run the Windows version of SheetCam on Linux.

Evening Les, another question for you!

I have an old laptop that I use for my vinyl cutter. It has windows xp home edition, it does not have a 25 pin printer port. (The machine with Linux on it links to the motor driver with the printer cable.) I was given a usb to 25 pin printer adaptor cable, Do you think I could install Sheetcam on the XP and use a usb output?

I have wineskin on my mac which is where I do my vinyl designs. Could sheetcam operate there?

thank you David
With luck I will get the legs under my table tomorrow and post a couple pictures.

You cannot use a standard USB to parallel converter. LinuxCNC/Mach rely on having direct access to the printer port. USB is simply too slow for this application. It is also generally a bad idea to use a laptop for machine control. Laptops have very aggressive power management which can interfere with the precise timing required for machine control.

SheetCam should operate under Wineskin. I know it works with WineBottler which is very similar.

Hi Les,
My Wine adventure did not go so well so I have version 3 back in there. I did solve the “error in line 11” problem that was caused by the default to ansi2000 or whatever it was! I deleted every option except emc plasma! Works beautifully now. Since I cannot figure out how to get up to the lastest Linux and tng I am attempting to pull just the svg filter out of a new version and stick it onto the one I do have. I would also put the drag knife in there so I can draw on paper before wrecking steel. If this is doable I would love some guidance.

Have my THC and just need a couple connectors to get it wired.


What happened when you tried to use Wine?

You can try copying the svg and knife plugins to the old version of SheetCam but I very much doubt if it will work. I have to admit I haven’t tried it so I can’t be absolutely sure it won’t work.

Install the new version is a different folder to the old version or simply unzip it. Go to the plugins folder and copy the knife and svg folders. Paste them into your old version. When you run the old version turn on the debug log (Help->debug log). Near the start of the log it should show if the plugins loaded successfully.

Hi Les, I’m not really sure what happened… My friend put the old stuff back in. We did then try to move the new svg and knife into the old version to no avail. When March rolls around I will get a different computer with more capacity and install latest Ubuntu and then also the latest Sheetcam until then I will get along with what I have. I am really looking forward to the SVG files though, I have lots from my vinyl program.
With luck I will have my machine all wired up by the weekend and make some smoke. In time I will put a watertight pan on the bottom and use a water bath to catch the smoke.