Importing files from CorelDraw

I am very new to the world of plasma cutting and its associated software. Learning more and more everyday, but still so much learn. Currently I need some help with importing files into sheetcam from coreldraw X8. I’m new to corel as well. I’m creating my files, (usually purchased files online or images that I’m grabbing from different sites, then redrawing or modifiying) reducing nodes, converting to curves then combining them before exporting them to DXF. They look clean and the arcs are smooth. When I import them into sheetcam, tons of nodes are added to the drawing, causing them to look distorted in many areas. Is there any way to reduce these nodes in sheetcam? Any other settings that I can use to “clean my files up”? I’ve been reading that SVG format is superior to DXF - is this true? My drawings may be the issue as well. Is there is anyone well versed in coreldraw that could give me some insight about potential mistakes that I’m making?

Thank you in advance for any help or advice you can offer!

I use Inkscape and have Found it better to export the file as an SVG into Sheetcam, also while you are in Corel Draw you need to delete some of the nodes, otherwise you will have 2 cut lines one on top of the other.

I have been finding dxf format import into sheetcam just fine these days.

A lot of the files you download can have lots of nodes, you can use the ‘reduce nodes’ in coreldraw, but don’t go to far or you loose detail.

Another good tool is the ‘smooth tool’ that does a nice job.

Thank you for your replies. I actually spend a considerable amount of time deleting nodes on each file. The only ones left behind are absolutely necessary to keep the correct shape. I’ve actually also tried saving a file in SVG format and importing to SC but it looks even more distorted than the DXF. I watched the youtube video on the smoothing tool - awesome, I’ll definitely be using that from this point forward.

I’ve included an attachment of a file that I created. To me, it looks clean in corel, but there are some distortions once imported into SC. It doesn’t look terrible but you can definitely see the increase of nodes as well as some wobbly lines, especially in the font. Maybe you can give me some insight. Thank you!

I took a look at your file. It indeed looks very nice in Corel Draw. It looks very good in CamBam. It looks bad in Sheetcam. What I saw in CamBam is that all the lines were Splines. It’s been my experience that splines do not play well with Sheetcam. When you save the file in Corel Draw, you need to experiment with what Autocad versions of dxf you save in. Some versions will save as splines, some will save as polylines, which Sheetcam likes much better. If you don’t want to go thru all of that, then you should just save in svg and life will be much easier. :smiley:


Save your file as desktop cutting plotter (autocad) dxf r14.

One other thing I saw in Corel Draw was there were 2 layers named layer 1, which gave an error when I went to save it. I don’t know if that’s your problem, but you might take a look at it.

Thank you once again for the suggestions…much appreciated. I’ve been following all of your advice, but still having issues.

  • I’ve tried exporting the file I posted earlier in 5 different autocad versions, r14 included, but didn’t see any differences in sheetcam.
  • I’ve tried to save an existing DXF file as SVG, but the export box shows an issue:
    Invalid ID’s Found
    Details: One or more IDs used in the file are either duplicates or contain invalid syntax.

Suggestions: Check all group, object and symbol instance names to ensure they are not duplicated within file and do not start with a number. Duplicate and invalid IDs will automatically be appended on export.

This may be referring to the layers you saw in coreldraw WyoGreen? I’m not entirely sure what that means. Do you know why there would be 2 layers and how I could eliminate one?

  • I’ve tried both just saving and exporting a new SVG file then importing into SC, they look far worse than my DXF file. It is most likely the way I’m going about it, though I don’t know what I’m doing wrong.

  • I’ve been researching on how I can possibly convert the splines in my drawings to polylines, but I’m not sure that’s even possible. I’m starting my new little business and I’ve created approx 30-40 files so far…I’m beginning to come to terms with the fact that I’m going to have to redo them because obviously the way I originally created them is causing problems. My concern though is how to create them without splines - the only drawing tools I’ve used up to this point are freehand, 2 point line and 3 point curve. I haven’t used the spline function at all so not entirely sure how my lines ended up being splines? Or why there are multiple layers for that matter.

Once again any advice/help/suggestions are most welcome and very much appreciated :confused:

In Corel click on Layers, if there are any layers you do not want to use click on the eye, and it will close the layer, if you want to put them all on 1 layer, transfer one to the other, if you want to export them into Sheetcam, do that and and seperate them in Sheetcam into seperate cutting layers,
In Sheetcam click on Options, Application options, Application options, click on tools, put a tick in the (remove duplicate lines) because like I said previously you have these in your drawing.
Now import the Drawing from corel as an SVG onto your desktop, import into Sheetcam and it will remove these extra cut lines, I have done this with your drawing and It cut fine, by the way I use Inkscape It’s free.
PS i am also new to all these programs. Try Youtube.

Good morning Dennis,

Thanks once again for the help. I’ve gone back into corel and removed the second layer from the drawing. I then imported the drawing as an SVG onto my desktop then into sheetcam. I had already ensured the remove duplicate lines box was checked. I’ve attached the file from sheetcam - its unrecognizable. An error message also came up regarding duplicate and overlapping lines, even though I removed the second layer in corel.

This has been a months long work in progress. I’ve used youtube, done extensive amounts of reading and have joined many forums, though I wish I had joined this one sooner. I’ve sought out help from corel…they don’t respond to emails like they say they will. I apologize for my basic questions and I really appreciate your patience :confused:

I’m beginning to wonder if this is an issue with the Sheetcam version or setup you are using. What issue of Sheetcam are you using? Under options/plugins is the DXF plugin enabled? Perhaps you need to download and reinstall the latest version for your operating system.


Hi Steve,

I have Sheetcam TNG. I received the license and downloaded it late December. I’ll try uninstalling and reinstalling it later today if I’m still having issues. I have to wonder though if its coreldraw. I have 2 test files - one is saved as DXF that I’ll attach to this post and the other is saved as SVG, that I’ll attach to a post immediately after. When I reopen the saved DXF, no problem. When I reopen the SVG its completely distorted. This is before sheetcam even comes into play. One thing I did find in sheetcam though is when I went to plugin options, the “Wire” plugin was selected. I selected DXF and clicked ok. I reopened the plugin tab right after and “Wire” was selected again with the message:
This plugin failed to load: Plugin is unlicensed.?

Test File 2 in SVG

His the test drawing only supposed to be 11.622 x 8.098 mm

No, I drew it at 11.3" x 7.3"

Thanks :slight_smile:

Hey JodiB,

On the plug-ins, you will find several that are unlicensed and active, must be the default. Anyway, go thru each of the plug-ins, and the ones that are unlicensed, un-check the enable box in the bottom left corner.
If you watch the message box at the bottom of the Sheetcam window, you will see the “failure the load” message quite a bit. I don’t think it hurts anything, but I figure un-enableing the the ones you can’t use anyway just cuts down on the error messages.
I ran into a bit of snag when I was trying to look at your svgs. I use the Linux version of Sheetcam, and it turns out the newest version won’t import svg files anymore. Hopefully Les will chime in pretty soon with what that’s about. So I went back to an older version, and now your svg and dxf’s load and look just fine. So I’ll start over at the beginning in my pondering on your problem.

I’ve tried to save an existing DXF file as SVG, but the export box shows an issue:
Invalid ID’s Found
Details: One or more IDs used in the file are either duplicates or contain invalid syntax.

The 2 layer ones were the cause of the above error, but that does not seem to be the cause of your problem. I’ll boot up as a windows 7 machine and look at your original files again and see what I see there.

Later, Steve

Opened your Test file from Inkscape both in SVG and DXF, they opened perfectly and cut perfectly first time no faults what soever, when saving from Inkscape I ticked the box to save as polylines not splines, I think this was your problem,
Good Luck.

So I opened the dxf and the test svg in windows 7 Corel Draw X8.
The dxf opened fine and looked fine. The svg was garbage.

I opened the dxf in Corel Draw and exported it as an svg. I then imported it back into Corel Draw and it was fine.

When I tried to open the original svg file in Sheetcam, I had an error message saying “This file version is no longer supported”, and nothing loaded in Sheetcam. The original dxf file opened in sheetcam with no problems. The new svg file also loaded into sheetcam ok.

One thing I did look at was the options for saving as an svg. I’m saveing as SVG 1.1, Unicode - UTF-8, Internal Style Sheet, Drawing precision 1:1000 units, Fountain Steps 256. The rest I don’t think matters.

So my current feeling is that your svg export from Corel Draw is flawed.


Thank you Dennis and Steve for taking the time…I’ve learned alot from your posts. I contacted the person I purchased my plasma table from (he works with all the same software, just an older version of corel). He was able to use remote access to get into my computer. After a couple of hours of seeing the issues I’m having, he found that it was the encoding in my corel program. He made the necessary adjustments and now I’m smooth sailing with SVG files - Steve you were absolutely right. Even after we figured this out though, there were still a fair amount of distortions in Sheetcam. We found that under Options, Application Options, Drawing Import that my settings were all different from his. Once I changed them to match his, my drawing looked 75-80% better. Its not exactly the way I want it to look, but leaps and bounds better.

Dennis, I’m still trying to get some answers from corel regarding the splines in my drawings. Perhaps once I get some clarification on that, I’ll be exactly where I want to be.

Thank you and have a great day! :slight_smile: