Floating Z axis problem

I’m new to this plasma cutting magic and I’ve hit a problem I can’t get my head around
My z axis doesn’t seem to be zeroing it’s self at touch off
I’ve set my 6.6mm so switch offset in post processor
For MACH3 I’ve got a vid showing what’s going on here
Any ideas ?

The switch offset should be the distance from when the switch clicks moving down to when the switch clicks moving up. Exactly. Jog your z down slowly until the switch clicks and zero the z then jog the z up slowly until the switch clicks. The offset should be what the z dro reads.
It looks like your z is adding extra distance every time it references. Does the z dro show zero when the switch is closed going down and then zero again after it retracts?

It looks like you are getting a different height every time. I have come across some Mach odditities when probing on older versions of Mach. What version of Mach are you using?
What post processor are you using?

Hi guys and thank you for your input
I have set switch offset as 6.6mm not sure if it should be a neg or pos number
post processor is Mach3 plasma with scriber and backlash compensation. the only edited part was the switch offset as mentioned earlier
here is the link to the test file out put from sheet cam
mach3 version is version R3.043.066

Try the ‘Mach3 thc with scriber’ post.

ok I used mach3 thc with scriber and got a strange result in mach3
it sends my cutter in circles all over the place
I have run the simulator in sheet cam and found everything ok
but also I have noticed that the torch turns off too soon as well you might have noticed this in the previous video
and isn’t sheet cam supposed to trigger mach3?
this is an image of my file in sheet cam https://www.dropbox.com/s/gwxhkt6afld9gkk/IMG_0639.jpeg?dl=0

In Mach go to Config->general config In the second column set the ‘IJ mode’ to Inc. If it is set to Absolute you will get these symptoms.

Thank you Les I’ll try that today :+1:t3:

sorry bout delay in reply my control board had issues
and victim of cyber hacking
Les I contacted you earlier by email but no reply
is there a chance of you resending my licence?

I can’t find your email. I’ll get a copy of your license sent to you.

Received thanks les great !
Now it’s back to the plasma cutting end of things

Ok using MACH3 with scriber post and still no touch off to zero and continuously rising z axis
I know the probe function is working and calibrated Z
Here’s a vid https://youtu.be/vQPCtXhEcKY

Is your probe input lighting up before the z starts going back up? It seems like you must be getting a phantom input in order for it to reverse.

Yes it definitely looks like the touch-off is tripping far too early. Are you sure the touch-off switch is wired correctly? In Mach3’s diagnostics watch the probe input while you run that job.

Yes the probe is functioning as it should I swapped over to NC active high and I created a simple little 40mm Square and ran it
All ran just as badly as before
Except this time I recorded the diagnostic screen and ran from there

That video doesn’t appear to be available. Is it marked as private?

I ran the g code single line by line and everything works perfect
But as soon as I cycle start it turns to custard
I’m thinking it’s either coms port speed or another crap control board
Though it’s weird that it does exactly the Same error at the exact same point every time

Are you using a macro in Mach3 to do the probing? Macros seem to have a problem skipping ahead when doing moves.
It also could be that you’re probing too fast causing it to overshoot the switch. What is your feedrate on your G31 move? I would think this problem should show up on single step as well as run.

No macros
But there’s a weird jump in line numbers when I run in single line mode and step to the next line
As in the vid here

M06 is a macro. It’s Tool Change in Mach3 T1 is tool 1.
Check the macro folder under the Mach profile and see what is going on in that macro.
I also see S500. That’s.a spindle speed command. Usually not used in plasma.
I don’t think these codes are in the Mach3 plasma post. Are you using this post?