continuous operation

As the heading goes and again this probably has been covered before, so please let me appologise in advance, how do you get continuous operation with nested parts and different operations. Please let me explain. If I cut one part that had two operations (marking and then plasma cutting) I have ‘clicked’ keep parts together, the marking is done then we then have to press ‘run’ on Mach3 to continue to finish the part. This is quite fine, however if we have 40 items for example we have to stand at the computer and when one part is completed, the plasma will go the the next part mark then stop and wait for the ‘run’ button to be pressed again. Especially if all is working perfectly this is anoying and I could be doing something else. I need to ‘keep parts together’ as plate can move, then the marking won’t line up with the cut part. I have done large jobs (6100mm by 1830mm) alli sheet and have done all the marking then the cutting, but would like to do the ‘keep parts together’ process. Any help would be very much appreciated. Thankyou

What post are you using? Check the ontoolchange function. There is most likely code for the pause in there since it happens when you go from marking to cutting. See what code line it stops at, then search for that code in the post and comment it out.

I am using a CandCNC post. DTHC-HTY-TAP_Softpierce+Marker=rev12D

I think there is a line right at the top that says Pause to check settings. You should be able to change that setting and get rid of the pauses. I think…

Yes. In SheetCam go to Options->machine->post processor and click on the ‘Edit post’ button. On about line 12 you should see something like this:

warnings = true  -- set this to false to turn off the Check Parameters warnings on a toolchange

Change it to:

warnings = false  -- set this to false to turn off the Check Parameters warnings on a toolchange

Gentelmen thankyou for your replies. I was hoping that there would be something that you can do in Mach3 or the computer running the G code. Ideally I would like to know if all is operating as it should then you can walk away (not too far) and let it go. At the moment I like to the pause at the tool change it is easier for me to recover from any issues when cutting. I may just need to get my head around this to be confortable. Thankyou very much, I now know that there is a way. :mrgreen:

You could get creative in Mach and make a macro that looks at the state of an LED, and pauses code if the LED is on. You would need to add a button to toggle the LED. Then just substitute the macro call where the original pauses are in the post.
This would allow you to decide if you want the pauses or not while the code is running.

Good afternoon, that sounds wonderfull, however I am not that smart :blush: Lots of things are possible when you know how, I am an old dog now and very hard to learn new stuff, in fact hard to learn anything at all :open_mouth:

Post a picture of your mach screen. I’m not sure what vintage of CandCNC table you have. If it’s the same as mine, I’ll poke around when I have some time and see what I can come up with.

Edit your post. At around line 677 you shoudl see this:

	post.Text (" M00\n")

Change it to:

	post.Text (" M01\n")

Now in Mach you should have an optional stop button. If optional stop is on, it will pause. If optional stop is off it won’t pause.

I don’t think the CandCnc screen set has that button. At least mine doesn’t.

Ah. That’s a shame.

Well good morning gentlemen, my version is 2013 and Mach3 has a stop button. Now I have tried to resize my screen shot photo of Mach3 but don’t know how to as yet, however My Mach3 screen does have a ‘stop’ button. The ‘stop’ button is in the bottom right hand side of the screen, where the green run, tanny feed hold, just slightly above and to the right of the ‘RESET’ button. I will have a look into the post at the line that you have suggested Les and see what I can make of it. I will report back. From my assumption, Les, I should be able to toggle the ‘STOP’ button on the screen for the pause. Now is there any other problems that this may cause. I very rarely ever hit the stop button, only if I have a trip with the plasma torch or there is a problem with the consumables, that need changing mid cut, again rare.

That STOP button just stops everything. There must be another button called optional stop that ignores the m1 command if it is toggled. I’m positive it’s not the normal stop button.

If your table is a 2013 then it’s probably the same screenset as mine. I’ll take a look and see if I can add the button for you.

Thankyou djreiswig. I got the software in about March 2013 and as you say the STOP button stops everything. I am very curious to see how this will work.

Try this. Unzip to your Mach3 folder. In Mach3 go to View…Load Screens. Pick the DTHCIV-EtherCut-Tab2-Opt-Stop.set file. There should be a button and LED in the bottom left corner. If the LED is green then it should stop on M1, otherwise it should keep running. You can toggle the button while the code is running.
DTHCIV-EtherCut-Tab2-Opt-Stop.zip (11.5 KB)

Thankyou for that I will try in the next few day and report back :mrgreen:

What I do is in Job Options/Nesting is set for minimize tool change. this allows all my marking to be done at one time, then I only have have to change my plaz back one time and finish cutting everything.

I like to complete everything on one part before moving on to the next. Then if something goes awry, I can move some parts around to save material. If you engrave multiple parts, you can’t adjust.