1" too high

I have my CNC since a couple of weeks so I’m a real beginner. I tried the standard Sheetcam demo and it word fine, so I bought the TNG version. Now the problem: I want to cut 0.1875 polycarbonate with 0.125 depth per pass, and with 0.5" rapid clearance. I make the G-code as usual, but when I put on cycle start, the tool goes 1.5" over the sheet instead of 0.5". Once at the start point, of course it goes down 0.625, so… it doesn’t cut! Here is the first lines of the G-code:

N0010 (Filename: 2810-HP70B .1875.tap)
N0020 (Post processor: Mach3.scpost)
N0030 (Date:11/11/2015 Time:21:18:26)
N0040 G20 (Units: Inches)
N0050 G40 G90 G91.1
N0060 F1
N0070 (Part: 2810-HP70B)
N0080 (Operation: Outside Offset, 0, T2: 0,1875 upcut, 0,25 inch Deep)
N0090 S8000 (0,1875 upcut)
N0100 T2 M06
N0110 G43 H2
N0120 G00 Z1.5000
N0130 S8000 M03
N0140 X1.5298 Y0.3745
N0150 Z1.0197
N0160 G01 Z0.875 F20.0
N0170 G02 X1.5235 Y0.3682 Z0.8750 I-0.0062 J0.0000 F40.0
N0180 G01 X1.4635 Z0.875
N0190 G02 X1.4635 Y0.3807 Z0.8750 I0.0000 J0.0062

I hope it’s something simple, I make side-by-side windshield and customers are waiting for me!

In your tool definition are you using any tool length offset? Most post processors simply add this to the Z height so a tool length of 1" would make the machine run 1" higher. If that isn’t the issue, look in Options->machine->post processor and make sure ‘Z zero’ is set to ‘Top of work’.

Ok, that was my tool length offset, now it’s perfect. Thanks!