6-1-62 question

Having problems with or questions about SheetCam? Post them here.
Post Reply
tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

6-1-62 question

Post by tinman13 » Mon Sep 09, 2019 2:08 am

Hi Les, just trying the new version and I get a message when Mach3 opens saying "Plugin DLL Defectice" , This seemed to happen the first time opening Sheetcam after the update. Is it related... or a Mach issue.
Thanks, Steve

tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

Re: 6-1-62 question

Post by tinman13 » Mon Sep 09, 2019 4:03 pm

A bit of an update. I did a system restore to a point just before loading V6.1.62 and the auto load plugin works fine but when I install V 6.1.62 Mach3 gives the defective plugin warning, so I assume it's something in V 6.1.62?
But, other that that the latest improvements work fine!
Thanks again Les for a great program!
Steve

User avatar
Les Newell
Site Admin
Posts: 2289
Joined: Thu May 11, 2006 8:12 pm

Re: 6-1-62 question

Post by Les Newell » Mon Sep 09, 2019 5:11 pm

Hi Steve,

That's odd. I just tested it here and I didn't have any problems. I have just uploaded an update for a different issue. Could you give that a try.

tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

Re: 6-1-62 question

Post by tinman13 » Mon Sep 09, 2019 5:34 pm

Les, sorry but still broken. Steve.

tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

Re: 6-1-62 question

Post by tinman13 » Mon Sep 09, 2019 5:59 pm

Further update, after I load either V.62 or V.63 I get the broken .Dll message and if I load an earlied version (the latest one I have is V.53) it still gives the broken .DLL message when Mach3 opens. The only way to fix it is with a system restore back about a week ago and then Mach opens with out an error.
Steve

luis lopez
Posts: 25
Joined: Sun Nov 24, 2013 12:44 am

Re: 6-1-62 question

Post by luis lopez » Tue Sep 10, 2019 7:17 am

This is the DLL error that comes out in version 62/63
Attachments
2º error.png
2º error.png (4.53 KiB) Viewed 95 times
1º error.png
1º error.png (3.03 KiB) Viewed 95 times

User avatar
Les Newell
Site Admin
Posts: 2289
Joined: Thu May 11, 2006 8:12 pm

Re: 6-1-62 question

Post by Les Newell » Tue Sep 10, 2019 3:39 pm

Could you go to c:\mach3\plugins and delete the SheetCamRemote file. Now reinstall SheetCam. Does that fix it?

tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

Re: 6-1-62 question

Post by tinman13 » Tue Sep 10, 2019 4:50 pm

Still no go... Actually, I uninstalled 6.1.63 , restarted, still get the message. The only way to get auto load working is with a system restore back to before 6.1.62 or 6.1.63 was installed.

User avatar
Les Newell
Site Admin
Posts: 2289
Joined: Thu May 11, 2006 8:12 pm

Re: 6-1-62 question

Post by Les Newell » Tue Sep 10, 2019 5:55 pm

Could you go to c:\mach3\plugins, right-click on the SheetCamRemote file and select 'properties'. Could you tell me the exact size of the file.

tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

Re: 6-1-62 question

Post by tinman13 » Tue Sep 10, 2019 6:10 pm

12.0 KB (12.288 bytes)
Attachments
Sheetcam properties.PNG
Sheetcam properties.PNG (294.67 KiB) Viewed 76 times

LesNewell
Posts: 904
Joined: Sat May 13, 2006 2:34 pm

Re: 6-1-62 question

Post by LesNewell » Fri Sep 13, 2019 5:21 pm

I figured it out. I was accidentally distributing a debug version of the dll. This will only run if you have Visual Studio installed. It ran fine on my computer but not on most others.

tinman13
Posts: 125
Joined: Thu Feb 07, 2008 9:20 pm

Re: 6-1-62 question

Post by tinman13 » Mon Sep 16, 2019 5:06 pm

Hi Les, Looks good on this end, working well!
Thanks again for a great program!
Steve

Post Reply