Arraying multiple parts

Having problems with or questions about SheetCam? Post them here.
Post Reply
TriplecCNC
Posts: 2
Joined: Sun Aug 04, 2019 7:10 pm

Arraying multiple parts

Post by TriplecCNC » Sun Aug 04, 2019 8:04 pm

I have a 48”x96” cutting area. I am trying to cut a part that is 23”x23”. When I array the parts, I can get 2 columns and 4 rows out of a sheet of High density plastic. The problem I am having is the left column is cutting the part an 1/8” wider on the x-axis than the right column, which is being cut correctly. The y-axis dimensions are correct on all parts. I am using mach3 to cut.

djreiswig
Posts: 121
Joined: Sat Feb 20, 2016 4:47 am

Re: Arraying multiple parts

Post by djreiswig » Mon Aug 05, 2019 3:36 am

Are the dimensions in the gcode correct? If the part is odd shaped it might be difficult to tell. Can you array a square and see if the dimensions are correct in the code?
Can you use the measuring tool in SheetCam to see if the parts are displaying differently for some reason?

User avatar
Les Newell
Site Admin
Posts: 2230
Joined: Thu May 11, 2006 8:12 pm

Re: Arraying multiple parts

Post by Les Newell » Mon Aug 05, 2019 10:55 am

Use the measure tool in SheetCam to check your drawing is correct. Right-click and select 'Measure'. Now click on a point of interest in your drawing. It will now show you the distnce from that point to the mouse cursor. If the drawing dimensions are correct your machine is probably losing position. Move your machine to 0,0 and mark the gantry and X axis carriage. Run the cut then move your machine back to 0,0. Do the marks line up? If not your machine is definitely losing position.

TriplecCNC
Posts: 2
Joined: Sun Aug 04, 2019 7:10 pm

Re: Arraying multiple parts

Post by TriplecCNC » Wed Aug 07, 2019 2:22 pm

I checked the part in sheetcam with the measure tool and the dimensions are correct. I also ran a test cut of the part without cutting anything. When it was done cutting, I hit go to zero in Mach3 and it was a 1/16th of an inch of from where I started it. I also checked to see if an inch of movement on the machine was an inch of movement on a ruler. I dont have a certified ruler for calibration but it appears as if it is correct. I still dont know why it would be wrong on the left side but correct on the right side of the sheet. I broke my bit this weekend and the new one should be here today. I will cut some tonight and let you know if it has changed any.

User avatar
Les Newell
Site Admin
Posts: 2230
Joined: Thu May 11, 2006 8:12 pm

Re: Arraying multiple parts

Post by Les Newell » Fri Aug 09, 2019 2:19 pm

That 1/16th of an inch shows your machine is losing position. Check for any mechanical issues such as binding, backlash or pulleys slipping on their shafts. Are you using steppers? Steppers are prone to randomly losing position if you run them close to their limits. Try reducing the acceleration and/or maximum speed. Another possibility is electrical noise. In that case careful attention to screening and grounding can make a big difference.

Post Reply