Sheetcam & CandCNC incorrect G-code

Having problems with or questions about SheetCam? Post them here.
Post Reply
slayder
Posts: 2
Joined: Thu Mar 28, 2019 9:40 pm

Sheetcam & CandCNC incorrect G-code

Post by slayder » Thu Mar 28, 2019 10:08 pm

Hello,

I'm in contact with CandCNC but so far it's been a dead end, at this time the machine is a very expensive brick.

My hardware consists of the following: CandCNC and Hypertherm 85A. CandCNC hardware was purchased December 2018.

1. Most Popular Bundle - Hypertherm 85 with CPC Port
2. SuperZ with Breakaway torch mount
3. HyT Connect RS485
4. PWM IIA Module
5. Mic-03 Cable – No Cable Filter
6. Linux Mini-PC

Problem:
This issue was not always there but once it starts then I cannot get it to work correctly. Sheetcam w/rev24 & rev26 from CandCNC is creating wrong G-code, (See sample code below). I've also linked 2 youtube videos below of the issue I'm having, any help would be greatly appreciated.

Tried the following:
I've updated to the latest version of Sheetcam, also tried uninstall/reinstall with no luck.

https://youtu.be/FKa0EsrQ6sw
https://youtu.be/5GnydOv__e4

BAD CODE:
(Filename: 20in line.tap)
(Post processor: CandCNCPlasmaLLCNC-rev26.scpost)
(Date: 27/03/19)
G20 (Units: Inches)
F10.0
G90 G40
G64 P0.010 Q0.001 (tracking tolerances set to 0.01)
M68 E0 Q10
(Part: 20in line)
(Operation: No Offset, 0, T18: 65 amp 1/4 steel)
M68 E0 Q900 (Global DTHC ON/OFF is ON )
G4 P.1
M68 E0 Q80 (Auto Preset is active )
G4 P.1
(Preset Volts: 127)
(Preset AMPS: 65)
( Air Pressure Preset: 75)
( Soft pierce is off )
( Suggested Tip Size: 65 )
( DTHC Delay: 1 sec )
( Min Cut Length for DTHC ON : 1 units )
M68 E0 Q3127 (Preset Volts set to 127 Volts)
G4 P.1
M68 E0 Q465 ( Preset Amps set to 65 Amps)
G4 P.1
M68 E0 Q875 ( Air pressure set to 75 PSI)
G4 P.1
M68 E0 Q510 (DTHC Delay set to 1 Seconds)
G4 P.1
M68 E0 Q10 (DTHC is OFF)
G4 P.1
(MSG, The PAUSE after this message is to allow the Operator to check the DTHC settings to confirn they are loaded from the G-Code and are correct. If you need to change anything do it before you hit the RESUME button to continue)
M1
G0 Z0.787
X0.000 Y0.000
G0 Z0.39
o<touchoff> call (external Touch off from Commandcnc)
G1 X0.000 Y0.000
G0 Z0.150
M3 S100
G4 P0.3
G1 X19.435 Z0.060 F90.0
M67 E0 Q10 (DTHC OFF)
X20.000
(End of job , noving to predefined Parking position)
G0 Z0.787
M68 E0 Q900
M68 E0 Q10 (DTHC is off)
G4 P.2
M5 M30


Unless I can get this solved by next week, I will be sending the Linux computer back to CandCNC for testing.

User avatar
Les Newell
Site Admin
Posts: 2179
Joined: Thu May 11, 2006 8:12 pm

Re: Sheetcam & CandCNC incorrect G-code

Post by Les Newell » Fri Mar 29, 2019 9:39 pm

I have to admit I'm not that familiar with Tom's post processors so I don't know much about why the DTHC isn't turning on. The move to cut height after the cut has started is definitely a bug in the post processor.
Could you post your job file and the post processor here. I'll take a look and see what I can figure out.

slayder
Posts: 2
Joined: Thu Mar 28, 2019 9:40 pm

Re: Sheetcam & CandCNC incorrect G-code

Post by slayder » Tue Apr 02, 2019 2:31 pm

Les,

thank you for looking into this. I've sent the Linux box back to CandCNC, attached is the job, tap files and the rev26 CandCNC post processor.

Thanks,
Dan
Attachments
20in line.tap
(1.37 KiB) Downloaded 2 times
20in line.job
(42.35 KiB) Downloaded 2 times
CandCNCPlasmaLLCNC-rev26.scpost
(38.86 KiB) Downloaded 1 time

Post Reply