Path rules bug ???

Having problems with or questions about SheetCam? Post them here.
Post Reply
mancavedweller
Posts: 40
Joined: Tue Feb 25, 2014 6:53 am

Path rules bug ???

Post by mancavedweller » Wed Jun 06, 2018 11:50 am

Hi Les,

I've put a path rule in my operation.

It's an "on inside corners" path rule. I have it set for corners less than 30 degrees, and to insert a code snippet 15mm before the corner, and another code snippet 15mm after the corner.

However, it's applying these rules at the very start of many leadins, on cuts that don't even have any inside corners less than 30 degrees.

I've attached the job file.

Cheers,

Keith
KEAYS MONOGRAM.job
(105.98 KiB) Downloaded 3 times
KEAYS MONOGRAM.tap
(53.91 KiB) Downloaded 3 times

SeanP
Posts: 84
Joined: Wed Oct 23, 2013 9:50 am

Re: Path rules bug ???

Post by SeanP » Wed Jun 06, 2018 2:22 pm

Hi Kieth,

If you set feed rate to say 99.8% for rule you can see where it's being applied.

It looks ok on mine.

Just as an experiment I ran you file with my post and tried it on the machine, just a dry cut, doesn't half pause where thc turns on/off, did you ever try S10/11 for thc on/off? you probably have it sussed anyway and different setup, just curious.

1.png
1.png (48.47 KiB) Viewed 102 times

mancavedweller
Posts: 40
Joined: Tue Feb 25, 2014 6:53 am

Re: Path rules bug ???

Post by mancavedweller » Wed Jun 06, 2018 11:16 pm

Cheers Sean,

I like your little tip about reducing the feedrate to 99.5% so it highlights everything.

In the screenshot you supplied, notice that the path rule is being applied in many places where it should not be applied. It's supposed to only be applied to inside angles LESS than 30 degrees, yet it's applying them to many angles that are greater than 30 degrees. The cut at the middle bottom of your picture shows this problem.

I tried altering the angles in the path rule from 10 all the way up to 80 degrees, and things still seem to be all over the place.

Tell me if I'm missing something. Sometimes I don't see the forest for the trees.

I moved from Mach3 to UCCNC. No pauses in motion with the THC ON/OFF stuff. When I first got UCCNC and one of their motion controller boards I did a lot of testing with a little gadget called a logic analyser. It basically records multiple logic I/O levels all at the same time at high speed. UCCNC has various "synchronous" outputs, which can be activated at precise points via gcode commands. These synchronous I/O outputs would come on/off at exactly the right time/location, and the step pulse stream remained completely unaffected. I even tested a change in feedrate and synchronous I/O change at exactly the same time and everything was good.

Using the Neuron THC with UCCNC.

I had a look at LinuxCNC and just gave up on it. No doubt with time and LOTS & LOTS & LOTS of technical forum chat I'd start getting somewhere with it but I'd rather stick with familiar Windows and just get going.

Keith.

SeanP
Posts: 84
Joined: Wed Oct 23, 2013 9:50 am

Re: Path rules bug ???

Post by SeanP » Thu Jun 07, 2018 9:45 am

I knew you would be on top of the game Kieth with thc on/off tricks, UCCNC sounds interesting don't think I have heard of that to be honest, must have a read up.
I must say I have found at times something not quite right with the corners rule, like you say the angles trigger doesn't seem just right, also on some corners I can't seem to find a rule to trigger, even all corners.
There is always action points to fall back on though, still a useful tool.

Post Reply