Chain cutting question

Having problems with or questions about SheetCam? Post them here.
Post Reply
tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Chain cutting question

Post by tinman13 » Tue May 01, 2018 3:13 am

When I duplicate parts the chain cutting doesn't seem to work but when the part is copied it will connect them fine. Is this the way it's supposed to work? Or am I missing something!

Thanks, Steve

User avatar
Les Newell
Site Admin
Posts: 1973
Joined: Thu May 11, 2006 8:12 pm

Re: Chain cutting question

Post by Les Newell » Tue May 01, 2018 8:40 am

I just ran some tests in SheetCam and duplicates appeared to work. Could you post the job file that demonstrates the problem.

tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Re: Chain cutting question

Post by tinman13 » Sat May 05, 2018 5:12 am

Hi Les, 1st part is the original and it doesn't chain to it's duplicate. I copied the part and made a copy of it and it will chain those two.
It seems like it used to work but I don't know if I have changed something or what...

Thanks again, Steve
Attachments
.500 link.job
(16.45 KiB) Downloaded 13 times

User avatar
Les Newell
Site Admin
Posts: 1973
Joined: Thu May 11, 2006 8:12 pm

Re: Chain cutting question

Post by Les Newell » Sat May 05, 2018 10:34 am

Huh. The problem shows up in both dev and stable, so it's been there for a long time. I will investigate further. Thanks for letting me know about this.

tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Re: Chain cutting question

Post by tinman13 » Sat Jun 09, 2018 4:05 pm

Hi Les,
Thought I'd add a couple more things. In version 6-1-50 when I post a job with the plasma1 post modified for flame cutting and have chain cutting enabled, (will only chain cut to a copied part (hint, hint!)) when it moves to the second part it is adding the preheat cycle to the operation. Needless to say this causes a bit of a problem!
I still have version 6-1-20 that I use for flame cutting and it functions correctly for both chain cutting a duplicate part and the pre-heating a second part problem.
Thanks, Steve
Attachments
6x6 14 ea.tap
(1.32 KiB) Downloaded 8 times

tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Re: Chain cutting question

Post by tinman13 » Tue Jun 26, 2018 1:16 am

Have you had a chance to look at this one yet Les? 8)
Thanks, Steve

User avatar
Les Newell
Site Admin
Posts: 1973
Joined: Thu May 11, 2006 8:12 pm

Re: Chain cutting question

Post by Les Newell » Tue Jul 03, 2018 4:00 pm

I have fixed duplicate chaining for the next release. I can't see anything obviously wrong with preheat. Could you let me have a copy of your post.

tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Re: Chain cutting question

Post by tinman13 » Fri Jul 06, 2018 5:50 am

Thanks Les, here it is.

Steve
Attachments
2 FLAME SCREEN preheat.scpost
(3.78 KiB) Downloaded 3 times

User avatar
Les Newell
Site Admin
Posts: 1973
Joined: Thu May 11, 2006 8:12 pm

Re: Chain cutting question

Post by Les Newell » Mon Jul 09, 2018 1:13 pm

I just tested using the job you posted. I deleted the duplicated outlines so i just had the chained parts. I only get one preheat cycle at the start of cutting. Here is the code for the transition between the two parts

Code: Select all

N0210 G01 X414.5882
N0220 G03 X415.4681 Y9.4920 I0.0000 J1.0160
N0230 X415.4681 Y112.1080 I-88.8681 J51.3080
N0240 G01 X418.2177 Y113.6955
N0250 (Part: Copy of  Copy of  .500 link)
N0260 X238.6118 Y131.2840
N0270 Y143.9840
N0280 X414.5882
N0290 G03 X415.4681 Y144.4920 I0.0000 J1.0160
N0300 X415.4681 Y247.1080 I-88.8681 J51.3080

tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Re: Chain cutting question

Post by tinman13 » Wed Jul 11, 2018 3:38 pm

Hmm... not sure I follow you there. Were the parts duplicated and chained?

User avatar
Les Newell
Site Admin
Posts: 1973
Joined: Thu May 11, 2006 8:12 pm

Re: Chain cutting question

Post by Les Newell » Wed Jul 11, 2018 4:25 pm

The parts were copied and chained. I used your example job and just deleted teh duplicated parts. I cannot replicate the issue you describe where you get a preheat cycle on a chained cut.

tinman13
Posts: 111
Joined: Thu Feb 07, 2008 9:20 pm

Re: Chain cutting question

Post by tinman13 » Fri Jul 13, 2018 3:13 pm

I'll do a bit more testing here and see if I can narrow it down.
Thanks, Steve

Post Reply