Drag knife not creating initial swivel

Having problems with or questions about SheetCam? Post them here.
Post Reply
catsh16
Posts: 6
Joined: Thu Apr 20, 2017 5:32 pm

Drag knife not creating initial swivel

Post by catsh16 » Tue Jan 23, 2018 3:29 am

Les,
~50% of the time - the drag knife code does not generate a preliminary swivel move for the very first cut of a program.
I have been inspect every program and editing if it is missing. I've been watching this trying to find a clue -but it's still a mystery
I have wanted to believe it is related to the exit angle of the last cut of the previously opened job file. but I haven't actually seen any correlation.

settings: lead-in arc: NO, lead-out arc: NO
currently running 6.1.38 (problem existed in previous versions as well). I am installing 6.1.50 right now

Image

- Kevin
Attachments
Leadin visable on screen but missing in code.jpg
Leadin visable on screen but missing in code.jpg (70.14 KiB) Viewed 223 times

User avatar
Les Newell
Site Admin
Posts: 1986
Joined: Thu May 11, 2006 8:12 pm

Re: Drag knife not creating initial swivel

Post by Les Newell » Tue Jan 23, 2018 9:15 am

Could you send me that job file (File->save job) and a copy of your post processor. I'll take a look and see if I can figure out what is going on.

catsh16
Posts: 6
Joined: Thu Apr 20, 2017 5:32 pm

Re: Drag knife not creating initial swivel

Post by catsh16 » Tue Jan 23, 2018 6:11 pm

I just emailed you the files.

User avatar
Les Newell
Site Admin
Posts: 1986
Joined: Thu May 11, 2006 8:12 pm

Re: Drag knife not creating initial swivel

Post by Les Newell » Wed Jan 24, 2018 10:54 am

SheetCam has to make some assumptions about the position of your knife. It has no way of knowing where the knife is at the start of the job so it assumes it is pointing in the same direction as the end of the last cut. As you are only cutting one outline the end result is that it doesn't add the lead in because it thinks the knife is already pointing in the correct direction.

To avoid alignment problems I generally recommend that you add a short straight line cut somewhere in a waste area. Make it the first cut. That cut will pull the knife into a known angle.

catsh16
Posts: 6
Joined: Thu Apr 20, 2017 5:32 pm

Re: Drag knife not creating initial swivel

Post by catsh16 » Tue Jan 30, 2018 5:59 pm

Do you know what angle it assumes the blade is at in the start of the part when sheetcam is freshly opened? If I knew that - then I could try to move my first starting point to match.
If you could read the angle (in the XY plane) of the first cut, and assume the blade is 110Deg offset it'd probably work fine.
I have been manually adding in a 0.1" straight in-line lead in at swivel depth and it is very reliable. It would save me a lot of time if I didn't have to do it manually.

catsh16
Posts: 6
Joined: Thu Apr 20, 2017 5:32 pm

Re: Drag knife not creating initial swivel

Post by catsh16 » Tue May 15, 2018 2:53 pm

Can you just create an additional parameter for the tool, or operation that automatically sets the assumed blade angle to a set direction (like Y+ ) for the first cut in a new job file. It could either be a fixed direction or an angle that the user assigns in the operation or tool dialog.
If it could be done like this... then the code would come out correct, and we could always manually rotate the blade to the designated orientation before starting a part.

This is still an issue that I spend a lot of time on... (creating >30 job file some days)
- K

Post Reply