Maybe a bug?

Posts redirected from the Yahoo mailing list
Post Reply
Brian L

Maybe a bug?

Post by Brian L » Sun May 03, 2015 12:23 am

Hi Les,

Been reworking some existing programs, long story, but because of a change in operating software on the mill, all my programs coded a year or more ago won’t run. So I have to open the job file, re-post the code and send it out to the machine. In the process of that, I’m checking my operations and when I highlight an operation and then right click it opens a box that has edit at the top of a bunch of choices, the problem is that box opens behind the Sheetcam window, I can only see the bottom edge of it sticking below the main window.


I worked around it by double clicking the operation and it opened the operation parameter window which allowed me to double check the depth of cut, steps and stock left.


In the process of doing that, I ran into a couple times where I wanted to change a layer or a tool number and again, the drop down boxes were not behaving correctly. I was able to highlight the layer or tool window, and using my up or down arrows on the keyboard, cycle thru the choices and change them.


So, all in all, I worked through it all, but it was odd to say the least. Now, I do run a iMac, using parallels with Windows 7, so it’s not impossible that this could hamper things, but it’s never done any of this before.
Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com









__._,_.___
Posted by: Brian Lamb <blamb11@cox.net>
Image

Visit Your Group
Unsubscribe ([email]sheetcam-unsubscribe@yahoogroups.com?subject=Unsubscribe[/email]) &bull; Terms of Use



__,_._,___

Les Newell les.newell@...

Maybe a bug?

Post by Les Newell les.newell@... » Tue May 05, 2015 1:35 pm

Hi Brian,

That sounds like a parallels issue. The operation editor windows are modal which means they should always appear on top of the parent (main window). The dropdown issue sounds similar. Dropdowns are separate windows that appear on top of the main window. If they aren't appearing on top, that would explain the symptoms you are seeing. Low level stuff like dropdowns and modal windows are handled by the window manager, not SheetCam.

Les


On 03/05/2015 01:23, Brian Lamb blamb11@cox.net (blamb11@cox.net) [sheetcam] wrote:
Hi Les,

Been reworking some existing programs, long story, but because of a change in operating software on the mill, all my programs coded a year or more ago won’t run. So I have to open the job file, re-post the code and send it out to the machine. In the process of that, I’m checking my operations and when I highlight an operation and then right click it opens a box that has edit at the top of a bunch of choices, the problem is that box opens behind the Sheetcam window, I can only see the bottom edge of it sticking below the main window. 


I worked around it by double clicking the operation and it opened the operation parameter window which allowed me to double check the depth of cut, steps and stock left.


In the process of doing that, I ran into a couple times where I wanted to change a layer or a tool number and again, the drop down boxes were not behaving correctly. I was able to highlight the layer or tool window, and using my up or down arrows on the keyboard, cycle thru the choices and change them.


So, all in all, I worked through it all, but it was odd to say the least. Now, I do run a iMac, using parallels with Windows 7, so it’s not impossible that this could hamper things, but it’s never done any of this before.
Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com










__._,_.___
Posted by: Les Newell <les.newell@fastmail.co.uk>
Image

Visit Your Group
Unsubscribe ([email]sheetcam-unsubscribe@yahoogroups.com?subject=Unsubscribe[/email]) &bull; Terms of Use



__,_._,___

Brian L

Maybe a bug?

Post by Brian L » Tue May 05, 2015 4:35 pm

Thanks Les, I’ll give a shot at shutting down everything and bringing it back up. When my software starts doing buggy things, that usually takes care of it. I wish more stuff would run natively on a Mac….
Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com






On May 5, 2015, at 6:34 AM, Les Newell les.newell@fastmail.co.uk (les.newell@fastmail.co.uk) [sheetcam] <sheetcam@yahoogroups.com (sheetcam@yahoogroups.com)> wrote:
Hi Brian,That sounds like a parallels issue. The operation editor windows are modal which means they should always appear on top of the parent (main window). The dropdown issue sounds similar. Dropdowns are separate windows that appear on top of the main window. If they aren't appearing on top, that would explain the symptoms you are seeing. Low level stuff like dropdowns and modal windows are handled by the window manager, not SheetCam.LesOn 03/05/2015 01:23, Brian Lamb blamb11@cox.net (blamb11@cox.net) [sheetcam] wrote:
Hi Les,
Been reworking some existing programs, long story, but because of a change in operating software on the mill, all my programs coded a year or more ago won’t run. So I have to open the job file, re-post the code and send it out to the machine. In the process of that, I’m checking my operations and when I highlight an operation and then right click it opens a box that has edit at the top of a bunch of choices, the problem is that box opens behind the Sheetcam window, I can only see the bottom edge of it sticking below the main window.

I worked around it by double clicking the operation and it opened the operation parameter window which allowed me to double check the depth of cut, steps and stock left.

In the process of doing that, I ran into a couple times where I wanted to change a layer or a tool number and again, the drop down boxes were not behaving correctly. I was able to highlight the layer or tool window, and using my up or down arrows on the keyboard, cycle thru the choices and change them.

So, all in all, I worked through it all, but it was odd to say the least. Now, I do run a iMac, using parallels with Windows 7, so it’s not impossible that this could hamper things, but it’s never done any of this before.Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com







__._,_.___
Posted by: Brian Lamb <blamb11@cox.net>
Image

Visit Your Group
Unsubscribe ([email]sheetcam-unsubscribe@yahoogroups.com?subject=Unsubscribe[/email]) &bull; Terms of Use



__,_._,___

Post Reply