Can't install linux version of Sheetcam

Having problems with or questions about SheetCam? Post them here.
Post Reply
aaron
Posts: 2
Joined: Tue May 14, 2019 6:51 am

Can't install linux version of Sheetcam

Post by aaron » Tue May 14, 2019 8:13 am

Hi
I am trying to install Sheetcam on a new Debian Stretch computer. These are the error messages I am getting:-

./SheetCamTNG-dev: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory
./SheetCamTNG-dev
./SheetCamTNG-dev: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory

Also running Sheetcam .exe through wine. There is no post processor for LinuxCNC

Please help

Thanks

User avatar
Les Newell
Site Admin
Posts: 2188
Joined: Thu May 11, 2006 8:12 pm

Re: Can't install linux version of Sheetcam

Post by Les Newell » Wed May 15, 2019 1:47 pm

I'm surprised it can't find wxWidgets. Does Stretch have a libreadline6 package? Also try installing libwxgtk2.8

aaron
Posts: 2
Joined: Tue May 14, 2019 6:51 am

Re: Can't install linux version of Sheetcam

Post by aaron » Thu May 16, 2019 4:52 pm

This is what I get when I try to install the packages you suggest:

aaron@######:~$ sudo apt-get install libreadline6
[sudo] password for aaron:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libreadline6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libreadline6' has no installation candidate
aaron@foam:~$ sudo apt-get install libwxgtk2.8
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libwxgtk2.8
E: Couldn't find any package by glob 'libwxgtk2.8'
E: Couldn't find any package by regex 'libwxgtk2.8'

Is there a solution?

Also How can I add a LinuxCNC postprocessor to a windows version?

Thanks

Aaron

Post Reply