V-Carve Path Issues

Les,

I’m looking for guidance on a V-Carve operation. See the two screen shot images that show what I am getting. I tried changing the step size and do get different results, but none provide a path that follows the letter exactly. I also changed the maximum depth and also tried different diameter and/or V degree bits which didn’t change anything on screen.

What else can I try?
Thank you…

Running:
Ubuntu 13.04
Wine 1.4.1
SheetCam TNG Development 5.1.19

Could you upload your drawing to try it , too ?

Thanks

Richard

Try dropping the step size a lot, say to 1/10th or even 1/100th of it’s current value.

Les,

I dropped it down as low as SheetCam will allow (0.001) and no change. Just before I got ready to upload the DXF, I notice that this problem may be related to Linux/Wine:

If I take the same drawing and open it on my test Windows installation of SheetCam, I can get acceptable results. If I open a job file which originated on the Linux install, the windows version shows the problems. If I open the good job on the Linux box that originated on the Windows install, the paths are acceptable.

Is it that way Linux brings in the DXF that is the problem since Linux can display the Windows version correctly?

Check the size of your drawing on the file you created on the Linux copy. It could be that you imported an inch drawing as metric. This will make it very small and coud cause the problem you are seeing.

Just checked. The drawing is unitless, but it’s width, 80, is what I would expect for metric sizing and that’s also what I usually work in.

It may still be worth checking the size in SheetCam. Right-click then select ‘measure’ and click on two known points.

I can’t think of anything else that would make a difference like this.

It’s also the same in sheetcam - 80mm wide by 50mm high. Or about that.

Les,

Can I copy the SheetCam TNG Development.ini file between Linux and Windows installations? And would those settings help me to compare my problem?

Can I send you the resulting .job files for your take on this?

Thank you…

Paul

Copying the ini files shouldn’t be a probkme but I’d be a little surprised if it fixed the problem. Cound you send me the two job files.

OK - Surprise.

So, the ini file does have, at least, something to do with this. I copied my Linux ini file to the Windows test box and the problems then occurred there, too. Returning the Windows box to it’s own created ini file gave me good paths.

I then copied the Windows version ini file over to the Linux box hoping to fix my Linux/Wine problem. When I started the Linux version with the Windows ini file, I was reminded of an issue I thought I took care of with this last development version (or the one prior). See the attached image showing the icons grayed-out. These icons are for showing tool path and rapids (on-screen only, apparently). While these icons are grayed-out, I cannot see any tool paths or rapids on screen. On the Linux box, using this Windows ini file, I could create the gcode which I imported back into SheetCam to prove to me that the carve paths were, indeed, correct just like the initial Windows install.

Deleting the ini file on the Linux install and letting SheetCam rebuild the file only fixes the icons and resulting on screen display. The funky toolpaths for the VCarve paths are still there.

And, in case I didn’t say it, I am running the 5.1.19 development on both.

!
Paul

I would really like to see the ini files and job files so I can figure out what is happening.

Zipped file has been emailed to support address.

Thanks in advance for any pointers you come across.

PK