SheetCam ver.3.0.17

I have a problem with the .tap file.
the drawing gets imported correct and the measurements fits, the simulation runs correctly and the measurements still fit. When the drawing is posted to Mach3.tap files the measurements are 10 times bigger then before. e.g 150 mm becomes 150 cm in the .tap file.
How do i solve this problem?

I would guess that you may have a calibration problem in Mach.

Do the numbers in the G-code look correct? It is easiest to see if you use a simple shape like a square and use no offset.

As i wrote previously, the measurements in the tap file is incorrect. 150.00 mm becomes 150.00 cm in the tap. Since Mach3 units 1.00= 1 cm, it must mean that 1mm in the drawing becomes 1 cm in the tap file.
How do i get the post processer to scale *0.1? i can’t find the place to input the value.

Mach3 should be set up so 1 unit is 1mm, not 1cm. Virtually all CNC machines use mm in metric mode.

According to ArtSoft mm is not an option. i’ve been using Mach3 and Lazy Cam for a few years without any problems. if SheetCam can’t scale the drawing i’ll have to continue my work with Lazy Cam.

You just set the steps per unit so that 1 unit is 1mm. I have a lot of Mach users and you are the first to have an issue with this. I use Mach on two of my own machines.

If you really want to use cm then you can do this by editing the post processor. In SheetCam go to Options->machine->post processor. Click on the edit post button.

Look for this code:

   if(scale == metric) then
      post.Text (" G21 (Units: Metric)\n") --metric mode
   else
      post.Text (" G20 (Units: Inches)\n") --inch mode
   end

and change it to:

   if(scale == metric) then
      post.Text (" G21 (Units: Metric)\n") --metric mode
      scale = scale / 10
   else
      post.Text (" G20 (Units: Inches)\n") --inch mode
   end

Thank You
That was what i needed