Printing in Sheetcam 6.0.11

I’ve been having a problem, not sure when it showed up, or if it’s always been this way. Just recently, I decided to print a copy of a job I’ve been working on. When I tried to print, another window came up, and all it displayed was black. There’s no heading on the window, so I’m assuming it’s a sheetcam window. I tried changing everything in the options to white, but it still only displays black in the print window. I tried the same thing on my backup computer, and it does the same thing, so I’m kinda thinking it’s a program issue. I’d certainly appreciate a little help, or a least a nudge in the right direction.

Thanks, Steve

Evidently, I’m the only one with this problem. I uninstalled and re-installed sheetcam, still had the problem. I then down loaded the program onto an old XP machine I had laying around. Printing works fine there. So I have to assume the problem is with Windows 7, the operating system I use on my Graphics machine. Looks like there must be some kind of a driver problem. Perhaps Les will chime in on this now.

Steve

It works fine on mine Steve, TNG and dev versions 64bit win 7

Sean

I think it must be a driver issue. SheetCam normally runs fine on Win7. In fact that is what I use for developing SheetCam.

Thanks for posting the screen shot Sean. That’s the same screen I get, but I get a black rectangle instead of the object I want to print. I get the black rectangle whether I have a drawing or a blank screen, and it’s always the same size. This happens on my Windows 7, 64 bit and 32 bit computers. The 2 computers are set up for different printers, one for an Epson, and one for an older HP. The XP machine is also set up for the HP printer. It appears that the screen that comes up when you click print in sheetcam is a sheetcam screen, which then sends the info to a printer specific screen to be printed. If so, then that leads me to assume that the driver issue is within sheetcam as it relates to Windows 7, since we’re actually not printing at this point, simply displaying a window of what we’re going to send to the printer. To me it seems like there is a communication issue between Sheetcam and the Printer display window. I’m still a loss as to where to go next, guess I’ll have to ponder on this a bit.

Thanks eveyone, Steve

Ok, after my last post I got to thinking. The problem I am having is on 2 almost identical Dell Optiplex 755 computers. After a bit of research on the web, it appears that Dell does not support Windows 7 on these computers. I did find some fixes for some driver problems, but these did not fix my Sheetcam problem. Since this is such a minor problem, I’ve decided not to pursue it any further and not worry about it. Everything else works fine. So thanks everyone for your help, and have a nice weekend.

Steve