Opening job with old tools crashes my system

I’ve recently “standardized” my toolsets (and rules) across both the Linux (tableside cutting) machine and my windows (office design) machine. I copied the tools from the Linux box to the Windows box, as the tableside tools are the “mo betterer” tools.

However, now if I open old jobs/part files on the Windows machine, I get errors that “xxx toolset/rule not found”. No worries, I go into the part, and change the toolset to the now-active toolset.

However, the warning doesn’t go away. Sheetcam starts running slower and slower, until it eventually locks my whole system up. Not every time, mind you. I’ve cut several jobs since this change was made, and of course I have no issues trying to run new jobs. Basically, I have issues 1) bringing in .part files with rule (or names) different than I have now, and 2) loading old jobs on remnant sheets, to finish them off.

Any ideas on how to get around this? I thought changing the toolsets/rules in the old .parts/job files to the new tools/rules would do it, but that does not appear to be the case.

are you using the same post processors on both machines

Yes, same post (27C, or whatever the newest one is called). Running latest Dev on windows machine, latest version on Linux.

Could you send me a support file. Go to Help->create a support file. Click the ‘Create file’ button them email to to me.

e-mail sent with support file, Les. I’ve also attached images of the error, and the constant scrolling that occurs. Thanks!

Sorry for the delay in replying - I have been away for a couple of days. I can’t replicate that problem but I don’t have your tool set. Could you send me a copy.

toolsets inbound. old.tools and new.tools. Thanks!

This may not help you entirely… but its worth trying…

when you load an old file with the old tools + rules, if you select the new tools and rules and press ok and the error message / exclamation mark remains.

Uncheck the operation checkbox and then re-check it to activate it, this seems to sort of refresh / re-run the operation and the exclamation disappears.

I’ve been doing some tests on this and still can’t get it to crash. The warning does remain until you disable then re-enable the operation or save/reload the job. Basically the changed rules get applied next time it has to re-generate the tool paths. When you see SheetCam slowing down, open task manager (press and at the same time). If task manager has a ‘more details’ button, press it. Look for SheetCam TNG Development and look at the CPU load. How high is it? It should be pretty close to 0.

I also can’t replicate the flicker. Select an part that has ‘could not fit leadin’ warnings and hover your mouse button over the operation. Does that popup box flicker?