New to SheetCAM - Two small problems (maybe?)

Hi, I just got to the point in my CNC plasma table build where I am testing the motion of my axes. I have spent some time with Inkscape/SheetCAM/LinuxCNC and I am able to go from drawing to g-code to motion. The follow may or may not actually be issues… maybe they are just a sign of my inexperience… LOL

These are the two issues that I am having:

  1. I am using the toolset file from CandCNC. All of the tools seem to wok fine (at least the ones that I have tried), but whenever I go to the top of the screen Tools → Tool Table, it crashes SheetCAM and closes. It will crash every time I try to to go into the tool table. Any ideas?

  2. Some files that I import into SheetCAM become invisible when I click the icon that looks like four arrows (nesting). This does not happen all of the time and I haven’t exactly figured out what may be causing it. Normally, the drawing will turn white and I can reposition the drawing on the sheet while in nesting mode, and then switch back to the arrow icon (scroll screen) to set the operation.

Any ideas of what may be causing this would be appreciated.

Thanks!

Not got a clue, but how about providing some specs for your PC, version of windows, version of sheetcam (have you tried the stable lockdown version)

Have you cleaned out temp files and folders using something like ccleaner?

Rob

Not got a clue, but how about providing some specs for your PC, version of windows, version of sheetcam (have you tried the stable lockdown version)

Have you cleaned out temp files and folders using something like ccleaner?

Rob

Sorry… I should have provided some more details. I will get some more details when I get home from work, but below is what I know off-hand…

This is a preconfigured system provided by CandCNC consisting of:

  • Computer: Dell Optiplex PC (32-bit processor)
  • OS: Linux (Xubuntu 14.4.04)
  • SheetCAM version - I believe it is the most recent 6.1.23, but I will have to check to make sure. I just received the system about 2 months ago and I believe they pre-installed the most recent version at the time when I bought the license.

Sorry, I know zero about Linux, other than I’ve tried many times to use it and always struggle with the syntax and end up back on windows.

Someone else running Linux + sheetcam may be able to comment, or Les may chip in.

Rob

Sorry - I have not been watching forum too much lately, myself. I see other’s getting there questions answered, but nothing on my previous question. Not sure what is going on.

I am not using CandCNC’s toolset. But if I was, I would make sure the post processor is the latest version, at least, is the one for the toolset. I would load a generic toolset to see if SheetCam runs without errors. I assume a tool has a value that is not understood, but I’m only guessing.

I am using Wine on Ubuntu running the latest development version, 6.1.27 and notice the vanishing part. Haven’t said anything yet - see above about not getting any response.

Paul

I have had a couple of reports of this issue in the Linux version. I will run some more tests and try to find out what is going on. You should still be able to use the tools window to edit your tools.

  1. Some files that I import into SheetCAM become invisible when I click the icon that looks like four arrows (nesting). This does not happen all of the time and I haven’t exactly figured out what may be causing it. Normally, the drawing will turn white and I can reposition the drawing on the sheet while in nesting mode, and then switch back to the arrow icon (scroll screen) to set the operation.

I have also had a couple of reports of this one as well. I am having trouble replicating the fault here which makes it difficult to figure out what is going on. Do you have any tool paths set up on those problem drawings?