New Install, Black Screen

Just installed V4.0.15 on a new Dell laptop and all I see a black screen. No material, machine or work envelope and nothing displayed when I import a drawing. The import process appears to be doing what it’s supposed to do, but nothing shows up on the screen.

I checked all of the system colors and they are all normal. I uninstalled and re-installed 3 times, deleted anything SC related from the registry and deleted and folders SC related prior to re-installing.

Any ideas? This is a customers PC that they bought just to do their CAD/CAM work.

This happens on some computers. As far as I can tell it is a bug in the graphics driver. Usually updating the display drivers does the trick.

No luck on this yet. It’s a similar issue that was reported a little ways down on the forum. The display is monochrome. If I set the color scheme to white and hide the table and work, the drawing shows up in black…and it does create gcode.

It’s an Intel video adapter on a Dell laptop. We updated video drivers and windows7 is up to date.

Any updates on this? My drivers are up to date and still having the same issue.

Works fine on my XP based PC hooked to my plasma cutter.

But does not run on my IvyBridge gen laptop w/ nvidia gpu.

Only way I’ve been able to get it to work is by right clicking the .exe and checking “Run in 256 Color” under “Compatability”.

I’ve since figured out a “solution” to this problem. My laptop will run the integrated graphics or the dedicated graphics depending on the setting and application requirements (i.e. integrated graphics for general use, dedicated for games).

Sheetcam is defaulted to run using the integrated graphics. I right clicked the executable and changed it to run on dedicated graphics and now I see the machine, material and drawing.

There you go. But, please, when you get time Les, look into allowing today’s latest SB and IB display adapters :slight_smile:

Thanks!

Could everyone having problems please post their graphics adapter make, model and if possible the driver version. I can’t replicate this fault here so I have no idea what is going on. I’ll try to find a computer with a similar card so I can replicate the fault.

I am also about to upload a new version of dev that does a bit of extra OpenGl error checking. Go to Help->Show debug log. If you see any messages starting with ‘OpenGl error’, please let me know exactly what the error messages are.

I have had a few more reports of this. It appears to occur on combined Intel/Nvidia graphics adapters on some new laptops. If your laptop has both Intel and Nvidia then forcing to SheetCam to run on the Nvidia graphics will solve your problem. You can either do this by right-clicking on the SheetCam shortcut and changing it to use Nvidia or through the Nvidia control panel.

From what I have been able to find out the Intel OpenGL support on these laptops is very limited and it should automatically switch to Nvidia for full OpenGl. For some reason the automatic switching does not work for SheetCam.

The last one, which was today, was an Intel 4000 (I think) graphics adapter with updated drivers. There was no Nvidia option. The last one we had did not have an option for Nvidia either. Right clicking the start icon and setting it run in 256 color mode got the colors back. Graphics were pretty bad looking at 256 colors, but perfectly usable.

I’ve just uploaded a new development version which may help. If this doesn’t work the debug log may show some OpenGL related messages (look in Help->debug log).

Can anyone tell me if you are using 32 bit Win7 or 64 bit? I am having trouble replicating this one.

It’s been on newer laptops which were all 64 bit.

The latest development release (V4.1.28) should fix this. Please try it and let me know how you get on. Sorry it took me so long to fix this one.

This did the trick. Thanks

I recently purchased a VIPER plasma running Mach3 & Sheetcam with Windows XP that I have a problem with. It came with a Dell preloaded with all the software basically plug & play, but when I open Sheetcam and go file>import drawing>choose my drawing file the file shows up in the part box but nothing in the black box at all. I think I have tried everything but nothing. I can go to work envelope, table display and see it as I set the parameters but as soon as I import the drawing the box goes straight to black. Any help will be greatly appreciated, Thank You

The first thing to check is that you have View->Show input paths and View->show tool paths turned on. If you have, go to Help->tutorials->titorial 1. Do you see the sample ‘CAM’ drawing?

Thanks Les I will try this and get back. Does the ‘CAM’ tutorial show how to fix the error or just give an example of my issue and how to fix? Thanks again

The main reason for recommending the tutorial is that it rules out any problems with your drawings.

Ok everything was checked liked you said. My part shows in
Parts box & checked but no part drawing. What to do? Thanks

The thing that is strange is that it worked when I first used it and cut a couple parts, turned it on and I can see the table in gray, material in maroon, and when export the drawing and pick the scale 1:1 and hit OK the whole drawing screen goes black. I click file new job, and the material, and table display comes back on. Where is the drawing going?

Also noticed that when you click the origin button on job setup or material setup, if I pick the lower left origin it shows up in the upper right origin, and so on. It is displaying just the opposite of what it is supposed to be. Its all messed up and cant figure out why. Any help??