Negative X and y axis showing up

With Sheetcam and Inkscape having upgraded we are now getting a beginning negative x and y axis when we upload the gcode to be cut. I do not know which program is causing this.

Going back to review: I have put an old design into Sheetcam and on the lower right it show both axis to be 0. This was done on the old Inkscape version. The design I am now working on with the updated Inkscape [1.0.2-2 (e86c870879, 2021-01-15)] shows x to be -.0001 and the y shows .0012. Why are they not both 0?

I went back to the old version of Inkscape 0.92 and redid the picture and I still get the negative axis in Sheetcam. Then I saved the picture as a PDF then imported it, saved it in Inkscape then imported to Sheetcam and still get the negative axis.

(Filename: Corey Mar 24 2021.tap)
(Post processor: CandCNCPlasmaLLCNC-rev24D.scpost)
(Date: 27/03/2021)
G20 (Units: Inches)
F10.0
G90 G40
G64 P0.010 Q0.001 (tracking tolerances set to 0.01)
M68 E0 Q10
(Part: Corey Mar 24 2021)
(Operation: Outside Offset, Color 1000000, T6: 16 gauge aluminum)
(Preset Volts: 105) (Preset AMPS: 45)
( Air Pressure Preset: 75)
( Soft pierce is off )
( Suggested Tip Size: 45 )
(Default DTHC Delay )
M68 E0 Q900 (Global DTHC ON/OFF is ON )
G4 P.1
M68 E0 Q3105 (Preset Volts set to 105 Volts)
G4 P.1
M68 E0 Q445 ( Preset Amps set to 45 Amps)
G4 P.1
M68 E0 Q875 ( Air pressure set to 75 PSI)
G4 P.1
M68 E0 Q711 (DTHCIV tuning set to level 1)
G4 P.1
M68 E0 Q10 (DTHC is OFF)
G4 P.1
M1 (Settings Check)
( ###########################)
(Paused: Check the DTHC Settings )
( Hit RUN to continue)
( ###########################)
G0 Z0.757
X16.026 Y10.030
G0 Z0.39
o call (external Touch off from Commandcnc)
G1 X16.026 Y10.030
G0 Z0.250
M3 S100
G1 Z0.062 F60.0
M67 E0 Q20 (DTHC is on)
G3 X16.080 Y10.079 I0.002 J0.051 F50.0
G1 X16.089 Y10.288
X15.611 Y10.293
X15.604 Y10.056
X15.593 Y9.729
X15.582 Y9.496
X16.055 Y9.486
X16.065 Y9.714
G2 X16.095 Y9.743 I0.030 J-0.001
G1 X16.378
This is the start of the Gcode. Second last line has the only negative. What is J?
I checked Sheetcam settings and they are all set at lower left.
I always use SVG when importing to Sheetcam so it will not be a DXF import problem.
I don’t know how to do screen shoots so I can’t show you what I see on Sheetcam other than to tell you that when I import the SVG the lower right says X axis is -0.0001 and y is 0.0012
When we go to cut, the plasma cutter goes to the first cut, fires and nothing more. (Doesn’t go down to touch off.)

Cross posted
https://www.candcnc.net/supportforum/viewtopic.php?f=24&t=3001&p=18073

Yes this is cross posted because I am looking for an answer that will help. Hopefully someone can tell me how to correct the problem.

I am not exactly sure what the problem is as I have never used LinuxCNC however this line looks suspect to me:

o call (external Touch off from Commandcnc)

o is not a valid start to a line in my experience, it seems to me like something is missing there… (and this looks to be where the touch off should happen)

The J is part of the G2 (circular interpolation command)
J is the distance from arc start-point to arc-center-point in Y-axis
I is the distance from arc start-point to arc-center-point in X-axis
So in your case the “real” J location is Y9.713

Hope that helps

The touch off command is correct for CommandCNC. It is an external routine.