Error in SheetCAM slot operation?

This is either a bug in SheetCAM, or I’m doing something silly.

3D CNC operation to slot (open path with no offset) 3.5mm deep in two passes. Each pass is ramped and the ramp is shorter than the length of the slot. “Reverse open paths” is on.

The first ramp (at 2mm deep) is backed-up and cleared down to 2mm depth. The second ramp (at 3.5mm deep) is just left in place. It’s not cleared away.

v6.9.6 on Windows 10 with all updates. Not seen this on earlier versions but maybe I haven’t been looking closely enough.

dxf, job, ngc, are zipped here. Screenshot also.

Anyone else seeing this? Or am I doing something stupid?

[attachment=1]SheetCamError.jpg[/attachment] (22.1 KB)

This is a bug and must have been around for a while. It was probably introduced in V6.1.58 when I added the option to ramp in to tabs as well as ramp out. It may take me a little while to fix this one.

As a workaround, reduce the depth per pass so you have 3 passes.

Thanks :slight_smile:

The issue occurs only on any pass made in the return/reverse direction. So you’re right, any odd number of cuts works.
Alternative workaround: turn off reverse-open-cuts.

Actually, a good refinement* would be to never clear out the ramp except on the final pass. That way the tool’s depth-of-cut would remain constant right through the whole operation, apart from during the entry-ramp and when cutting-away the final ramp. The present method (cleaning up the ramp at the bottom of each depth) adds some moves that aren’t needed.

*With reverse-open-cuts off


Thanks :slight_smile:

You’re right - any odd number of cuts works OK because odd-numbered cuts always have their ramp cleared. (DOC increases at the end of the cut, though, due to the unintended ramp material.)

Alternative workaround: turn off reverse-open-cuts/


This is fixed for the next release. I always worry about working on the path generator code. It is extremely complex and it’s easy to inadvertently break something else while fixing a problem.