edited postprocesors don't work

Hi, I have a problem with editing postprocesor on my plasma PC.
I need to modify PlasmaRotary Mach3 postprocessor, but any change gives me errors and I can’t post .NC files any more.

In postpocesor window:
Lua: Error occurred while opening file
cannot open C:\Documents and Settings\Uniwersał Plasma One\Dane aplikacji\SheetCam TNG\posts\PlasmaRotary Mach3 uniwersal.scpost: No such file or directory

After posting .NC file:
An unexpected error has occurred:
Post not found
This error occurred on line 1178 in file …\Camlib\postmacro.cpp)
Post processing failed

I tried to put postprocessor file in diffrent locations, copy original, edit it in Notepad and put it as original. Nothing works, only original, not modified postprocesors work ok.

I’m on Win XP.

thanks in advance

The posts supplied with SheetCam are stored in Program Files along with SheetCam. Due to file permissions on later versions of Windows it is not possible for normal users to edit any files in Program Files. To get around this when you edit a post in SheetCam it copies the post to application data (in your case C:\Documents and Settings\Uniwersał Plasma One\Dane aplikacji\SheetCam TNG\posts). I am guessing that Lua doesn’t like the ‘ł’ in the path. It should work so I will look into why it doesn’t.

In the mean time you can edit the post in c:\program files\SheetCam TNG\posts. You will have to use Notepad or a similar editor and you may need to have administrator permission. Note that if you edit a post in this way you need to either restart SheetCam or re-select the post in Options->machine->post processor for the changes to take effect.

“ł” letter was a problem, solved.

Thank you very much.