drilling with plasma

Trying to centerdrill with plasma - using drilling operation with plasma tool.

Bulltear plasma table, CandCnc DTHC, Autocad and/or Bendtech Pro SM, Sheetcam, Mach3.

I’m getting the drawing geometery and centerpoints in Sheetcam, and the simulator runs correctly.

Then after post process, there is no code for the centerdrill, just tool header info.

I’ve gone over the TNG manual and searched forums, but didn’t really find what I’m doing wrong.

In the drawing, tried both using circles and points. Circles were .3, with max/min set to .5/.1. Both work to make drill pierce points in Sheetcam. Neither show up after post process in G-code. iirc, the post processor is called MP3000.

Any help would be appreciated!

Jan MacLean
Dartmouth NS Canada

That is a post processor problem. Your post is not set up for drilling. Go to options->machine->post processor and click on the ‘edit post button’. Copy and paste this code into the end of the file:

function OnDrill()
   OnRapid()
   OnPenDown()
   endZ = drillZ
   OnMove()
   OnPenUp()
   endZ = safeZ
   OnRapid()
end

Save the file and close the editor. If this does not appear to fix the problem go back into Optionns->machine->post processor and make sure you select the edited version of your post.

That’s what I figured

Excellent service, thanks.

yep, worked perfect. No issues, good first part.

Thx again.