Drilling operation not working

Hey guys.
I am using V Carve Pro to make DXF files, SheetCam 7.0.10, Hypertherm Powermax 45 and a 48x96 AvidCNC plasma table.

All is working well… except for the drill operation! I’d like to make a small holes that I can drill out with a drill press later.

I make a simple part in V Carve Pro. One layer for the part, one layer for the holes. I export it as DXF.

I import the DXF into SheetCam with “Use points for drilling” checked on the “Drawing options” dialog.

I start with a drilling operation, select the HOLES layer. These holes are 10mm diameter, min hole is set to 1mm, max to 20mm. When I click “Ok”, SheetCam seems to identify and mark them correctly (though… no thick green dot, as I would expect?).

In this test I am using 2mm thick sheet mild steel, but the problem exists regardless of the thickness.

I simulate it in SheetCam, it looks good, appearing to do pierces at the centre of the holes.

I run the post processor in SheetCam, it makes a TAP file as expected.

I load the TAP file into Mach 4, and the drill operations are simply not present. If I run the Gcode on the table, only the outside part is cut out - the hole instructions seem to just be ignored.

I use the above workflow for a bunch of other tasks, and they cut exactly as expected… only drilling operations are not working right.

In this shared Google Drive folder is an image of each step, along with the TAP file, DXF and CRV (V Carve Pro) files.

https://drive.google.com/drive/folders/1hYV6Z-DTSwUYwEGieH6Y_m8mINYAXmic?usp=sharing

What am I doing wrong? (Or is this a question for Mach?)

Thanks.

Are you sure you’re using the correct tap file? Looking at ‘metal tub design.tap’ you appear to have two operations. The first is a no offset on INTERNAL_HOLES and the second is a no offset on MAIN_PART. I don’t see any drilling operations.

argh, I uploaded the incorrect file, sorry - the correct TAP file is there now, test hole pierce.tap.

My apologies.

That looks like a bug in your post. If you send me a copy of the post processor I’ll fix it for you.

Thanks Les, that would be great…

I got my plasma table from Avid CNC (https://www.avidcnc.com), and used their toolset and post preset. Their file is an executable (from SheetCam Software Setup - CNC Software), looks like there’s a new version which I installed. From their release notes, the issue I reported here has not been fixed in the new version.

I went to edit the Post Processor in SheetCam (I made no changes) and saved a version, now attached to this forum post (I was not sure where to find the post processor on my computer - trust this is ok?).

Could you also let me know what you changed, so I can let Avid CNC know they should update on their end as well?

Many thanks!
Avid CNC Mach4.scpost (10.2 KB)

This should fix it.

I added function OnDrill() to the post.
Avid CNC Mach4.scpost (10.3 KB)

Thanks Les, I incorporated that… the result is closer to what I need, but still not right: it drilled the holes correctly, but from from the second hole (on the left) to the next position, it has the plasma torch on for the rapid move, cutting a divot into the workpiece!

See attached image. The circled pierce was an earlier test, ignore that. This image shows two attempts with the new post processor, side by side.

I have attached the .tap file also.


hose holder.tap (7 KB)

I can’t see why the torch isn’t turning off. However I do see that the torch isn’t lifting as it should. Give this a try.
Avid CNC Mach4.scpost (10.4 KB)

Thanks Les, that solved it!

Much appreciated! :mrgreen: