Code Problem?

Hi, I have recently returned to using Sheet Cam after a year or so break but I am now having problems.
After using the post processor when I run the code on the 3040 cnc machine the Z axis will not rise
and it damages the work instead of a rapid move. How can I get SheetCam to perform a rapid move correctly?

Regards
Roy

What post processor are you using? If you look at the G-code do the Z positions look roughly right? If the code doesn’t make sense to you, post a copy here on the forum and I’ll take a look.

Hi Les
Many thanks for your reply. I am using the post processor that comes with Sheet Cam it has just downloaded
the latest software version. I think the problem is this line of code no 140 Z0.5000 In a previous tap file the
code was No 140 GOO Z4.000 therefore if i am right the Z Axis only lifted 0.5mm and G00 was missing.
How can i make the post processor write the code correctly?
Regards
Roy

SheetCam comes with a lot of post processors. You can find which one you are using by hovering your mouse over the ‘run post processor’ button or by going to Options->machine->post processor.

Just a thought - go to Options->job options and take a look at the rapid clearance. What is this set to?

Hi Les,
The post processor is mach3 and the rapid clearance set is 4mm ( this has always been the same
as i have never changed it. I am thinking that it must be a problem with mach 3 then?

Roy

Hi Les,
I have another little problem that you may be able to help me with?
Each time I load G code and ref all dro to zero. The Y Axis dro starts to continusly
change giving minus numbers until I press reset. The normal button changes
to green saying abnormal condition. When I click on that button the message
reads “Axis are not refered to normal condition” Could you please help with
a solution to cure this problem?
Many thanks for your help and understanding

Roy

Each time I load G code and ref all dro to zero. The Y Axis dro starts to continusly
change giving minus numbers until I press reset.

Do you have homing set up correctly? When you ref all home the machine should move slowly towards the home switches. If you don’t have home switches, they aren’t working or they aren’t configured correctly it will just keep going until it hits the limits. You probably want to zero the axes rather than home every time.

Does the g-code look roughly correct? Don’t worry too much about what the g-codes mean. Just look for the Z coordinates.