Climb milling check box has no effect

I must be overlooking something but I’ve tried opening the outside contour and go to the cut path tab and check the “climb mill” box but still the outside contour path is conventional milling (counter-clockwise) when viewed in the simulator

What am I doing wrong?

Problem report zip file attached.

Sage

I think I figured this out.
Seems you have to press the “optimize now” button (also on the cut path tab) for the climb mill checkbox change to take effect.

IMHO this is not intuitive since this button is not even in the same segment of the dialog.
Perhaps there should be a “save changes” or “activate” click box near(er) the climb mill box or simply a change in the climb mill check box initiates the re-calculation.

Perhaps there’s another way I’m missing?

Sage

This is a bug and will be fixed in the next release. Disabling then enabling the operation (use the little check box next to the operation) will also force the paths to regenerate.

The bug will be fixed in the next release.