All MP1000-THC post don't work

I allowed sheetcam TNG to do an automatic upgrade, and it hasn’t worked right since. I have been using TNG on a widows 7 operating sytem for a year and now that I allowed this upgrade the MP1000-THC posts do not work anymore. I have tried them all even the MP3000-DTHC. I’m planning to install the new MP3000-THC and would like for this to work.
Every time I try to run the post processor I get a message- an unexpected error has occurred …gram Files\sheetCamTng\Posts\MP1000-THC-Z ref.scpost:158: attempt to compare nil with number This error occurred on line 1079 in file. Post processing failed.
I have tried other plasma posts, like Mach3 plasma and the post work fine.
Can you tell me what happened? What was changed in the software that I don’t see. I am forced to use an old version of sheetcam not TNG to do all my work now.

Cfwfab


Thanks for the response. I created a support file for a part, I hope it help with figuring this out.

Thanks,
Cfwfab

Could you send me a support file. Load a job or set up a new one then save it. Next go to Help->create a support file. If you email the file to me I’ll try to work out what is going on. You can use the ‘create and upload file’ option but it is less reliable and you must make a note in the extra information box to let me know who it is from.