Search found 2208 matches

by Les Newell
Tue Jul 16, 2019 11:31 am
Forum: Problems and questions
Topic: Odd behaviour on first job loading
Replies: 13
Views: 420

Re: Odd behaviour on first job loading

I have been very careful to maintain job file compatibility between versions. If you load a newer job file into an older version of SheetCam any new features will be ignored but the rest should load correctly. Newer versions of SheetCam should of course load older job files with no issues.
by Les Newell
Tue Jul 16, 2019 9:29 am
Forum: Problems and questions
Topic: Nesting mode
Replies: 7
Views: 78

Re: Nesting mode

I really need to think on this one. I am trying to find a way to have one set of operations applied to all parts. Unfortunately the way I designed SheetCam internally makes that difficult. Not one of my better design choices.
by Les Newell
Tue Jul 16, 2019 9:26 am
Forum: Problems and questions
Topic: .part not saving path rule selections with part
Replies: 7
Views: 55

Re: .part not saving path rule selections with part

I have a list of stuff that needs to be fixed. This should have been on the list but wasn't. I have now added it to the list. I am slowly working through the list as I get time but I'm not sure when I'll get to this one.
by Les Newell
Mon Jul 15, 2019 11:52 am
Forum: Problems and questions
Topic: Little holes in my work
Replies: 4
Views: 46

Re: Little holes in my work

That does sound like stray lines in your drawing. Make sure rapid moves are turned on (View->show rapids). If you look at the blue rapid moves and see one that goes somewhere unexpected you can zoom in closer to see what is going on. Turn on View->show path ends. You will now see white dots on the e...
by Les Newell
Mon Jul 15, 2019 11:46 am
Forum: Problems and questions
Topic: Odd behaviour on first job loading
Replies: 13
Views: 420

Re: Odd behaviour on first job loading

can i run both on one PC? Yes you can. The dev version installs independently of the stable version. You will need to install your license on the dev version as it won't see the stable version's license. It is fine to use the same license on both as long as they are both on the same computer. Yeste...
by Les Newell
Sun Jul 14, 2019 7:20 am
Forum: Problems and questions
Topic: how can ı fix the licence issue?
Replies: 5
Views: 78

Re: how can ı fix the licence issue?

Go to Options->job options and increase the rapid clearance to be higher than your pierce height.
by Les Newell
Fri Jul 12, 2019 4:13 pm
Forum: Problems and questions
Topic: how can ı fix the licence issue?
Replies: 5
Views: 78

Re: how can ı fix the licence issue?

It was a post problem. This post appears to have some missing code (a function called checkangle). I took out the part that references that missing code so the post should now run. I can't guarantee that your machine will run correctly as I don't know what that missing code did.
by Les Newell
Fri Jul 12, 2019 3:17 pm
Forum: Problems and questions
Topic: Opening job with old tools crashes my system
Replies: 8
Views: 96

Re: Opening job with old tools crashes my system

I've been doing some tests on this and still can't get it to crash. The warning does remain until you disable then re-enable the operation or save/reload the job. Basically the changed rules get applied next time it has to re-generate the tool paths. When you see SheetCam slowing down, open task man...
by Les Newell
Fri Jul 12, 2019 1:51 pm
Forum: Problems and questions
Topic: how can ı fix the licence issue?
Replies: 5
Views: 78

Re: how can ı fix the licence issue?

That is a problem with the post processor, not the license. If you send me a copy of the post I'll take a look and see what is going on.
by Les Newell
Fri Jul 12, 2019 8:46 am
Forum: Problems and questions
Topic: something is wrong
Replies: 2
Views: 34

Re: something is wrong

What exactly is the problem?
by Les Newell
Thu Jul 11, 2019 8:35 am
Forum: Problems and questions
Topic: Opening job with old tools crashes my system
Replies: 8
Views: 96

Re: Opening job with old tools crashes my system

Sorry for the delay in replying - I have been away for a couple of days. I can't replicate that problem but I don't have your tool set. Could you send me a copy.
by Les Newell
Mon Jul 08, 2019 12:54 pm
Forum: Problems and questions
Topic: Kerf Width, is it available to the post processor / code snippets?
Replies: 2
Views: 31

Re: Kerf Width, is it available to the post processor / code snippets?

Kerf width isn't available to path rules. It is available to the post processor as the variable 'toolDia' but that means you need to edit the post processor to use the variable.
by Les Newell
Thu Jul 04, 2019 12:49 pm
Forum: Forum help
Topic: About Post processor: MP1000-THC.scpost
Replies: 3
Views: 38

Re: About Post processor: MP1000-THC.scpost

Go to Options->machine->post processor and click the 'Edit post' button. Starting on around line 100 you should see this code: function OnPenDown() if(dist >= (refdistance/scale)) then dist = 0 -- modaltext (" G00") -- text(" Z") -- number (pierceheight * scale, "0.0000") -- eol() post.ModalText(" G...
by Les Newell
Tue Jul 02, 2019 4:20 pm
Forum: Problems and questions
Topic: Post Processor help for Centroid Mill Control
Replies: 6
Views: 83

Re: Post Processor help for Centroid Mill Control

It took me a little while to figure out what is going on. The post processor does not know anything about M25. Before the tool change it lifts to the clearance height. After the tool change it assumes it is still at the same height. After the tool change it moves to the cut start X,Y then should rap...
by Les Newell
Tue Jul 02, 2019 2:56 pm
Forum: Problems and questions
Topic: Post Processor help for Centroid Mill Control
Replies: 6
Views: 83

Re: Post Processor help for Centroid Mill Control

Hi Brian, Sorry for the delay in getting back to you. 1. When calling a new tool and it moves to the first XY position, I would like to have a move to safe Z level, usually Z.1" in my case, sometimes it does this, sometimes it leaves it out and it will feed from Tool Change position all the way to t...