sheetcam.com Forum Index sheetcam.com
SheetCam discussion board
 
 Forum SubscriptionsForum Subscriptions    FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Maybe a bug?

 
Post new topic   Reply to topic    sheetcam.com Forum Index -> Yahoo posts (yahoo @forum.sheetcam.com)
View previous topic :: View next topic  
Author Message
Brian L



Joined: 26 May 2012
Posts: 161

PostPosted: Sun May 03, 2015 12:23 am    Post subject: Maybe a bug? Reply with quote

Hi Les,

Been reworking some existing programs, long story, but because of a change in operating software on the mill, all my programs coded a year or more ago wonít run. So I have to open the job file, re-post the code and send it out to the machine. In the process of that, Iím checking my operations and when I highlight an operation and then right click it opens a box that has edit at the top of a bunch of choices, the problem is that box opens behind the Sheetcam window, I can only see the bottom edge of it sticking below the main window.


I worked around it by double clicking the operation and it opened the operation parameter window which allowed me to double check the depth of cut, steps and stock left.


In the process of doing that, I ran into a couple times where I wanted to change a layer or a tool number and again, the drop down boxes were not behaving correctly. I was able to highlight the layer or tool window, and using my up or down arrows on the keyboard, cycle thru the choices and change them.


So, all in all, I worked through it all, but it was odd to say the least. Now, I do run a iMac, using parallels with Windows 7, so itís not impossible that this could hamper things, but itís never done any of this before.
Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com









__._,_.___
Posted by: Brian Lamb <blamb11@cox.net>
[img]http://geo.yahoo.com/serv?s=97476590/grpId=12675264/grpspId=1705007389/msgId=16755/stime=1430612628[/img]

Visit Your Group
Unsubscribe ([email]sheetcam-unsubscribe@yahoogroups.com?subject=Unsubscribe[/email]) &bull; Terms of Use



__,_._,___
Back to top
View user's profile Send private message
Les Newell les.newell@...
Guest





PostPosted: Tue May 05, 2015 1:35 pm    Post subject: Maybe a bug? Reply with quote

Hi Brian,

That sounds like a parallels issue. The operation editor windows are modal which means they should always appear on top of the parent (main window). The dropdown issue sounds similar. Dropdowns are separate windows that appear on top of the main window. If they aren't appearing on top, that would explain the symptoms you are seeing. Low level stuff like dropdowns and modal windows are handled by the window manager, not SheetCam.

Les


On 03/05/2015 01:23, Brian Lamb blamb11@cox.net (blamb11@cox.net) [sheetcam] wrote:

Quote:
Hi Les,

Been reworking some existing programs, long story, but because of a change in operating software on the mill, all my programs coded a year or more ago wonít run. So I have to open the job file, re-post the code and send it out to the machine. In the process of that, Iím checking my operations and when I highlight an operation and then right click it opens a box that has edit at the top of a bunch of choices, the problem is that box opens behind the Sheetcam window, I can only see the bottom edge of it sticking below the main window.†


I worked around it by double clicking the operation and it opened the operation parameter window which allowed me to double check the depth of cut, steps and stock left.


In the process of doing that, I ran into a couple times where I wanted to change a layer or a tool number and again, the drop down boxes were not behaving correctly. I was able to highlight the layer or tool window, and using my up or down arrows on the keyboard, cycle thru the choices and change them.


So, all in all, I worked through it all, but it was odd to say the least. Now, I do run a iMac, using parallels with Windows 7, so itís not impossible that this could hamper things, but itís never done any of this before.
Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com











__._,_.___
Posted by: Les Newell <les.newell@fastmail.co.uk>
[img]http://geo.yahoo.com/serv?s=97476590/grpId=12675264/grpspId=1705007389/msgId=16757/stime=1430832902[/img]

Visit Your Group
Unsubscribe ([email]sheetcam-unsubscribe@yahoogroups.com?subject=Unsubscribe[/email]) &bull; Terms of Use



__,_._,___
Back to top
Brian L



Joined: 26 May 2012
Posts: 161

PostPosted: Tue May 05, 2015 4:35 pm    Post subject: Maybe a bug? Reply with quote

Thanks Les, Iíll give a shot at shutting down everything and bringing it back up. When my software starts doing buggy things, that usually takes care of it. I wish more stuff would run natively on a MacÖ.
Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com






On May 5, 2015, at 6:34 AM, Les Newell les.newell@fastmail.co.uk (les.newell@fastmail.co.uk) [sheetcam] <sheetcam@yahoogroups.com (sheetcam@yahoogroups.com)> wrote:
Quote:

Hi Brian,That sounds like a parallels issue. The operation editor windows are modal which means they should always appear on top of the parent (main window). The dropdown issue sounds similar. Dropdowns are separate windows that appear on top of the main window. If they aren't appearing on top, that would explain the symptoms you are seeing. Low level stuff like dropdowns and modal windows are handled by the window manager, not SheetCam.LesOn 03/05/2015 01:23, Brian Lamb blamb11@cox.net (blamb11@cox.net) [sheetcam] wrote:
Quote:
Hi Les,
Been reworking some existing programs, long story, but because of a change in operating software on the mill, all my programs coded a year or more ago wonít run. So I have to open the job file, re-post the code and send it out to the machine. In the process of that, Iím checking my operations and when I highlight an operation and then right click it opens a box that has edit at the top of a bunch of choices, the problem is that box opens behind the Sheetcam window, I can only see the bottom edge of it sticking below the main window.

I worked around it by double clicking the operation and it opened the operation parameter window which allowed me to double check the depth of cut, steps and stock left.

In the process of doing that, I ran into a couple times where I wanted to change a layer or a tool number and again, the drop down boxes were not behaving correctly. I was able to highlight the layer or tool window, and using my up or down arrows on the keyboard, cycle thru the choices and change them.

So, all in all, I worked through it all, but it was odd to say the least. Now, I do run a iMac, using parallels with Windows 7, so itís not impossible that this could hamper things, but itís never done any of this before.Brian Lamb
blamb11@cox.net (blamb11@cox.net)
www.lambtoolworks.com













__._,_.___
Posted by: Brian Lamb <blamb11@cox.net>
[img]http://geo.yahoo.com/serv?s=97476590/grpId=12675264/grpspId=1705007389/msgId=16758/stime=1430843734[/img]

Visit Your Group
Unsubscribe ([email]sheetcam-unsubscribe@yahoogroups.com?subject=Unsubscribe[/email]) &bull; Terms of Use



__,_._,___
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    sheetcam.com Forum Index -> Yahoo posts (yahoo @forum.sheetcam.com) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group